Problems with Clip already? Won't charge, won't connect! Please help!

A couple weeks ago I bought a Sansa SanDisk Clip on eBay. The day I got it, my hard drive crashed. Then I discovered that my external hard drive, where I had backed up all my information, had also failed at the worst possible time.

I am definitely not in the mood to deal with anything broken technological crap.

Now, this thing was able to charge when I got it. I didn’t had any music, as I’d lost it all in the crash, but I did plug it in and listen to the radio a little bit. It charged, lightning bolt etc.

Now when I plug it in (NOW THAT I HAVE MUSIC) it does its little SANDISK screen, says “Connected” for a moment, and then does the SANDISK screen again. Repeat ad infinitum. It’s not charged so I can’t reset it because it dies on me before then. It’s not showing up on my computer as an external hard drive (I’m on a MacBook), so I can’t update the firmware. It’s not charging, either, in case you hadn’t picked up on that.

It was working. Now it’s not. Please tell me there is a way to fix this thing easily. I do not have the energy to fight with electronics anymore. I just want to listen to music at the gym.

Search these forums for how to force it in to MSC. It defaults to MTP which is windows proprietary, so you will havr to use MSC. Also check this site out. It is what I consider “The Bible” for mp3 users on macs

Guyscharf on wordpress

Yes but it’s not even showing up as a drive and it’s not charging. It ought to do that, it did before.

I can’t really do anything to it if I can’t access it and can’t reset it. (Not charged = no resetting.)

Starting with the Clip OFF, slide the power switch down to the HOLD position (orange showing).

Press and hold the center button while plugging in.  This will force an MSC connection, and the device will begin charging.

Bob  :smileyvery-happy: