Problem with my Sansa plus and switching computers?

I have a 8gb Sandisk Sansa clip plus.Recently I switched from windows to Ubuntu and though the player is full with music,the folder (MSC mode) is empty on the computer! I assume that’s because I used windows/windows media player and MTP mode.When I transfer new music,It appears normally both on the player and the computer.But the old music that plays normally on the player - seems to be gone on the computer.what can I do to fix it?!

Thank you

I assume it’s the MSC/MTP mode issue:

When your player is connected to your computer under USB MSC mode (set under the player’s Settings/USB Mode), your computer only sees the files that had been transferred to the player when the player was connected under MSC mode.  Likewise as to MTP mode.  Regardless, all the files show up and are playable on your player, under whatever USB mode setting.

A good reason why some people prefer to set the USB Mode on their player to either MSC or MTP:  on the Auto setting, the player tries to connect under MTP mode but then will fall back to MSC mode if the MTP connection does not work; the result being, you may have a mix of MSC and MTP mode transferred files on your player, making some of them not visible on your computer without switching to the other USB mode. 

Because MSC mode is more universal (playing with a broader range of operating systems, including Linux and on Macs, and without a need for Windows MediaPlayer on the computer), some people prefer MSC mode.  However, note that DRM (digital rights management) files need MTP mode–they will not transfer sufficiently (the DRM license will not transfer) under MSC mode.

If you currently have a mix of MTP and MSC mode music on your Clip, you can:  set the Clip to the mode you want to “delete” from your player; connect to your computer; copy your music to your computer and delete the originals from your Clip; disconnect your Clip from the computer; set your Clip’s USB mode to the other mode, the one you want to use in the future; reconnect your Clip to the computer; re-transfer your music from your computer to the Clip; and disconnect.  And now, keep the Clip’s USB mode set to that mode (it can re-set after a firmware upgrade–always doublecheck it after an upgrade).  Voila!