PC doesn't detect Clip+ internal memory

I recently installed a new hard drive in my laptop and reloaded the OS and drivers. Now the PC fails to recognize my 8gb Clip+'s internal memory content. It still detects the SD card inserted in the player though.

What can I do?

Are you using MTP or MSC mode on the Clip+?

I have tried both MTP and MSC. I have also tried installing it as new hardware. It worked fine until I installed the new hard drive and restored the OS.

I assume you are using windows (one shouldn’t have to assume by the way). If you are, in msc mode see what device manager shows. If it shows a yellow exclamation mark, remove the entry and the device, then try plugging in again. If it shows as ok, take a look at disk management. If it shows without a drive letter, assign one. I don’t know why any of this shoudl be necessary, but windows will sometimes do funny things. It’s sort of similar to doing a mount in linux, although that seems to be automatic these days.

When I hover the pointer over the music folder it says the folder is empty. However, in properties, it acknowledges that there is over 7gb of content (music files) on the player. When I open the music folder, again it appears to be empty, yet all the music files are accessible on the player itself. I have just reinstalled the firmware and the problem persists.

You might try reformatting the Clip and/or reapplying the firmware–sometimes those steps can fix unknown issues.

@rheis wrote:

When I hover the pointer over the music folder it says the folder is empty. However, in properties, it acknowledges that there is over 7gb of content (music files) on the player. When I open the music folder, again it appears to be empty, yet all the music files are accessible on the player itself. I have just reinstalled the firmware and the problem persists.

Files loaded in one USB mode (MTP or MSC) cannot be seen by your computer while connected in the other mode. I’m sure if you disconnect, change the USB Mode setting to the other one (from what it is set to now), and re-connect you’ll fiind your computer sees your Music folder as having songs in it.

Btw, The Auto setting (or Auto Defect as we like to call it here) can connect in either mode without your knowledge, but defaults to MTP whenever possible. Because of this, nobody here ever recommends using it. :wink: