Windows doesn't recognize Clip+ files

My computer model is a:

Model #: p6140f
PCBRAND: Pavilion

OS: Windows 7

Several months ago I loaded my Sansa Clip+ with music… The next month I then downloaded the Sansa Clip+ updater desribed in this forum. I then tried to reconnect my Clip + to my computer, but I kept getting an error message saying that my computer did not recognize the harddrive of the Clip+.

I read the SanDisk forum which told me to remove the updater program, which I did, and tried to reload my Clip+ onto my computer. My Clip+ harddrive now has different file names than what they originally were and nothing is in them. Yet, my Clip+ is saying that 3.48 gb of the Clip+ hardrive is full…

I am confused!

If you have any questions please ask. I would like to get this resolved as soon as possible. Thanks :slight_smile:

Can you turn your Clip on and does it start up normally?  If so, go under Settings and choose the Format option.  This will clear your Clip out of all of its content (but not the player’s operational files) and then all should be well to start fresh.

Probably an MTP/MSC issue.

Yes, and Milkerman who is usually right on should have suggested this first. My clip+ decided to set itself to auto mode for some strange reason. Once you become familiar with what you normally see in one of other mode, you can usually spot when settings has switched. I don’t know why my clip did this, it’s been ok since then.

Is there any way to do this without deleting everthing on the hard drive? I had a very important interview which I recorded with ‘Voice’ and I don’t want to delete it!

With the player off, you might try connecting the player to your computer with your USB cable, while holding the center button down.  That sometimes can force a connection.  At that point, you can run chkdsk on your player via Windows and set it to correct any errors; perhaps that would fix matters.  Or, you could transfer your content back to your computer and then reformat the player under its Settings.  

@thetypest57 wrote:

Is there any way to do this without deleting everthing on the hard drive? I had a very important interview which I recorded with ‘Voice’ and I don’t want to delete it!

Just save (copy) it to your computer before formatting. Then you can transfer it back to the player if you want. If I recall correctly, the FM & Voice recordings must be accessed while connected in MTP mode. After copying to your computer though, you can transfer this file back in MSC with no problems.

I was able to copy the files out of the Voice mode and on to my computer. Then I went to settings and reset the player to factory settings. First, resetting the clip plus didn’t wipeout the device. I still had all my music and was able to access it on my computer per usual. Second, for two days I have played it for about 3 hours each day and it just shuts off and I cannot reboot it for at least 10 hours.

When I am able to reboot it. It shows that the battery is dead. I can’t help but think that there is a systems malfunction that I can’t clearly see.

Is this a MTP/MSC issue? I have all my files under MTP subfile. If I clear the entire Clip+, reset it and shift to MSC, will it boot and function properly?



Resetting won’t clean the files off your device.  Rather, you want to go under Settings and choose Format --that will clear off your content and often fix issues.  And if you can’t do that on your player, you can try doing it via Windows, with the player connected to your computer.

As to MTP vs. MSC modes, MSC often will work with few glitches (as opposed to MTP mode, which often will have some).  Unless you need MTP mode because you have DRM’ed files, I generally recommend MSC mode (and almost never Auto mode, which may use both modes, confusing matters, potentially). 

Good News: I have changed USB mode from MTP to MSC mode. Naming is fine. I haven’t found any old labeling problems.

Bad News: For the past 3 days, after about 1-2 hours of using the Clip+, it dies. Just shuts off. I checked to see what the power level was before it shut off this last time and the battery was full. I even connected it to my computer and it didn’t power on.

Any thoughts?

If you have any questions, just ask! :smiley:

You might try manually reapplying the latest firmware (see the firmware upgrade sticky thread at the top of the forum)–the firmware can become corrupted over time.