problem with firmware updating

Hello! I got my new clip (8 GB) today and I’m totally happy about it. Everything seems to work well, the only problem is to update a new firmware. I’ve searched the forums already, but didn’t saw a similar problem. However, I appologize if this is a silly question, but I’m a mp3player-newbie. :wink:

I have the file on my PC and unzipped it, but I can’t copy or drag and drop it into the root directory of the clip. Somehow there is no option to paste it in the root directory. I mean, normally in the menu (of windows) you can select the option “paste”, but in the root directory this option is disabled. In the folders (music) I can copy and paste my music files without no problems. I’m using Windows XP and copy the files manually. Am I doing something wrong? Thanks in advance.

Get to a window where you can see all the folders on the device.  (Music, Audibooks,  etc)

Put your cursor below the last folder,  ( or anywhere other than on top of an existing folder) right click,  and you should be able to paste it there.

Message Edited by sansafix on 12-17-2008 03:12 PM

I tried to do this and in this window pasting is enabled, however I  still can’t copy/paste the file, because this time I get an error message that it’s not the right file type for the device.

OK heres your work around.

Unplug the device.  Go to settings>  USB Mode>  Select MSC

Connect the device to the computer.

Place the firmware file on the root.

Unplug,  it will update.

Also,  you might want to update your computer to WMP11.

After the update you can switch your USB mode back to Auto,  MTP or MSC  (if you want to access DRM content such as Rhapsody or Overdrive,  Netlibrary,  you should select MTP mode).

This time it worked!! Thank you so much for your help!! You’re doing a great work with this forum! :smiley:

 Also thanks for your other advices, but I rarely use WMP and never tried DRM content so far. I prefer the simple USB or MSC mode. :wink:

Thank you! (My problem is Stop charge in 1 minute then auto shut off, and my PC not detect with Sansa updater…) I followed your way its work charging by PC right now. After updated but when I open My Coputer its show Sansa Clip and then I open each foler… All folder display Empty (really I loaded mp3) but still playing with mp3 song I loaded 2 weeks ago… I am not trying to load more music yet, if it possible to load more music in Music folder I will post later

My question is How to upload music?