PC now doesn't see files on Fuze after firmware update

Before I updated the firmware to v01.02.31P, whenever I connected my Fuze to my PC (Windows XP) it was seen as a separate drive (e.g. F:) in Windows Explorer - “Devices with removable storage” and I had no problem using drag & drop, delete files etc and download podcasts from websites. Since I updated the firmware, whenever the Fuze is connected to the PC it is now seen instead as a Portable Device in Windows Explorer in “My Computer” with Internal Memory and External uSD Card

However, all my existing music files are not “seen” - e.g. i.e. the folders are now shown as being empty, even though the “properties” of the internal memory shows significant used space and Windows Explorer can’t see the files that I have put on the Fuze.

Can anyone help with getting Windows to “see” my music files, or is it possible to roll-back the firmware.


Updating the firmware reset the USB mode to MTP or Auto-detect (it was in MSC mode before). Files transferred in one mode are “invisible” to your PC when connected in the other mode, as you’ve discovered.

Just go into Settings>USB Mode and change it back to MSC if you prefer the way things were before.

Thanks very much - it works fine now I’ve changed the usb mode. Apologies - I should have consulted the manual before panicking!!

Just wanted to add that your response solved my problem. I hadn’t updated the updater and hadn’t changed any of my settings - the USB was always set to “Auto”, but after a recent System Restore and then use of the Norton Removal Tool to remove NIS 2011 to do a clean install of NIS 2012, for some reason my Fuze was no longer recognized by my computer. Changing the USB setting to MSC now causes the Fuze to be recognized by my computer, the Sansa Updater to appear on my computer screen, and my Fuze to start charging. So kudos for the help!