PC not acknowledging files on fuze?

This is kind of hard to describe, but…

I installed the latest firmware, added a video (I converted it using video4fuze). After I disconnected the fuze, it asked me to set my language/region. Since I moved to Asia recently, instead of North America, I set my region to “rest of the world.”

And now when I connect the fuze to my PC, the PC thinks the fuze is a USB drive or something. I can’t see what files I have on it (though I could when I started this whole excercise) and I’m afraid to add any files in case that messes things up. The Fuze itself still shows me all the files, but I can’t acess them from my PC. I’ve tried synching it to Windows Media Player, but even that just tells me that the Fuze has no songs on it (which is patently not true). It does recognize that only 2gb of my 8gb are available though, and that those 2 gigs aren’t the full amount of available space.

  • Was it the firmware?

  • When I added the video, I just drag&dropped it into the fuse’s video folder – did that break it?

  • How do I fix this?

Thank you for any help!

Settings/System Settings/USB Mode. Change it to MTP, which is probably what you were using before.

Your firmware update must have switched the USB mode. Apparently you were using MTP before, and now you’re in MSC. Your computer can only see files that were sent over in the current mode, although your Fuze sees everything.

By the way,  drag-and-drop won’t work on video, though that didn’t cause your problem. You have to put video through a converter to make it fit the Fuze screen. The Sansa Media Converter, available through the updater, makes many people unhappy, so try Video4Fuze. Download the .exe file on the right side of the page and install it.

Ooohhhh. Thank you so much, that fixed it. Hahaha, that was a lot simpler than I thought it would be.