One specific mp3 freezes player

I just bought the clip zip today and of course am running it through it’s paces.  So far so good with one exception.  I have 1 specific mp3 that locks the player when i try to play it.  When i say lock i mean the menus still respond, i can navigate around, but the song won’t play, nor will any other song that i attempt to play after it, the now playing screen always reverts back to the original problem song’s info.  After a reset, all other songs work fine again.

Problem song info:

256 kbps 44 khz

1:27:32 duration (full DJ set)

2 channel stereo

Protected: No

I re-encoded the file to a lower bitrate but still no luck.  This file works fine on PC, tablet, phone, etc.  I’m able to play other files with longer durations, higher bitrates…so i’m kind of at a loss for what else to try.

Any suggestions? TIA

** EDIT **

Now i’m even more stumped.  I converted the problem MP3 back to wave, then took that wav file back through Lame to a nice new 160 kbps mp3.  Same issue.

Are threre any tagging programs you are using? If you are, make sure you are using ISO-8859-1 characters (your program may also refer to it as “ansi”).

My guess–and it’s entrely that–is that the issue has to do with the play length.  

As I mentioned above i am able to play other files that are longer play length.

After much, much, more troubleshooting I finally decided to try forcing MSC for the USB mode and that resolved it.  For some reason, this one very specific song just would not work using MTP, which is what Auto was selecting.

So, in case anyone else stumbles onto this post in the future, if you are having problems with any of your songs on this player, with files that work fine on all other devices…go to Settings > System Settings > USB Mode and change from Auto to MSC, then recopy the file.  I make no promises but it worked for my headache.

MTP = Most Troubelsome Protocol.

MSC = Mode of Sansa  Champions

:stuck_out_tongue:

MTP = M ost T roublesome P rotocol

MSC = M ode of S ansa  C hampions

:stuck_out_tongue: