2GB Clip - Freeze After First Song

This just started happening the other day out of the blue. My 2GB clip is running the latest firmware 01.01.32A and nothing changed before or after this issue started (no new song or anything).

Basically, you can choose one song, any song, and it will play. However once the song is over or you skip to the next song the clip will lock up. I can listen to the FM Radio without any issues.

I have tried the following:

 - Format & Reset via settings menu

 - Format via Windows Disk Management

 - Downgrade firmware to .30 and back Up to .32

Any ideas?

Also forgot to mention, if I play a song and pause it, then go to the radio it works fine. However, when I try to go back to the song and resume it the clip will lock up.

Nobody has any ideas?

More info.  Does this happen with every song, or just some?  What kind of files?  How are you getting your music?  What mode do you transfer in?  Have you tried other file formats?

This is my father’s clip, he likes to listen to music while he rides his bike and jogs.

Any / every song. The files are MP3. They were converted from CD to MP3 via WMP. The mode is autodetect which I guess defaults to MTP since the music was transferred via WMP.

I haven’t tried other file formats, but I’ve tried some of my MP3’s which play fine on my clip. Same issue… You can choose any song initially, but as soon as you try to skip to the next song the clip will lock.

There was no new music added to the device before this issue started happening. The only thing my father does is plug it into the USB port on the computer every now and then to charge the battery.

I found a site with older firmwares, and tried downgrading to the .20 version. Same issue… :frowning:

It’s weird, because I would of expected a hardware issue to prevent playback entirely. But if I’m the only one experiencing this I don’t think it would be a software issue.

I guess I’ll try a couple songs in a different format and see what happens, but I’m not going to hold my breath.

EDIT: Just tried some .wma songs… Same issue… will lock after playing initial song.

Message Edited by TheMadBeaker on 05-13-2009 11:19 AM

I would back up the stuff on the player, if it’s not already, and then format it using the Clip’s format command.  Then re-load whichever flavor of firmware you like, then re-load a few songs to test.

If you’re not using DRM-crippled music, I’d suggest using MSC mode.  It doesn’t preclude using MTP in the future if you want, but is (to me) more simple.

After re-reading your original post, I see you’ve already tried that.  I think I’d call 1-866-sandisk to see what they have to say.

Message Edited by tenzip on 05-13-2009 03:07 PM

Well, I did the email support thing and in the end it’s being RMAed for an exchange… No hassles at all, they even pay for the shipping.