Locks-up if more than 20 songs loaded (MSC mode)

I just installed the latest firmware (V01.01.17A installed 12/02/07), then tried MSC mode for the first time.  If I load only 20 or so DRM-less mp3 files, it does OK  (under the “MUSIC” folder). But when I try to put any more than 20-25 or so mp3’s on my Clip in MSC, it will lock up on the infamous “Refresh Database” screen (have to reset player).  Remove enough of the files, and it will refresh OK.  I tried reformatting the player through it’s menu system, but still locking up.  I also tested with a couple of diff. batches of mp3 files, just in case the lock-ups were due to corrupt files.  All these files transfered fine in MTP mode, and my mp3 tags all appeared to be OK, at least the id3v2 ones. Is anyone else having this issue?  Can corrupt id3v1 tags cause this?  Any insight would be appreciated as I would really like to use MSC mode.  Other than this, I have no complaints at all about this player.


I did find out that if the Clip locks-up no big deal, just hold the power button in the up position until it shuts down (10-15 secs).  I then have to reconnect in MSC mode and delete some files (delete enough of them so it quits locking up, I still don’t know *exactly* what the “magic number” of files is, it seems to vary a little).  Also I thought maybe creating an M3U file was the issue at first, but deleting it still resulted in lockups.  I tried a few diff. folder structure secnarios, which seemed to have no effect either.  Again, any help would be appreciated.

same thing happened to me… narrowed to one file that clip didnt like…ipod has no prob with it.
 i ripped it myself.  then, i loaded it from mtp mode and no prob… i hate this procedure.  dont know whats wrong. 
i wanna know what happens when you do same thing from mtp mode.

OK, I figured it out.  Just downloaded Mp3Tag v2.39 and made sure everything on the Clip was tagged properly.  My previous version of this software was much older than 2.39.  Turns out you must have track numbers for each and every single file, and possibly a genre tag for each one also.  Didn’t realize my track numbers were missing, that’s probably what was freezing the database.  All this tagging sounds like a lot of trouble, but you can easily change tags a folder at a time with Mp3Tag (big folders will take several minutes, but at least it’s not labor intensive, just kick back and let it go).  It doesn’t bother me if every song is track 10 (!), as long as my Clip works in MSC mode.

looky there, i used the app you did. i  changed nothin in names–left everything as is.  ran it (i dont see any visual diff in output tag).  loaded ““new”” from msc and now worx fine… good for me…this is buggy as **bleep**; hope not too many songs do this, but still i ll take it…the apple/itunes/ipod can be a major pita also…

I had the same problem.  Ended up having one m4a file mixed in, and one corrupt mp3.  De-selected them for my next drag & drop and everything was fine.

what/why was the mp3 corrupt?  does it play on other players?

amkoas, I believe Mp3Tag writes the tag info from id3v2 (which it shows by default) over into id3v1.  That maybe why you got the file(s) to suddenly work you were having problems with. This leads me to believe the Clip firmware looks at id3v1 tags if it finds nothing (or garbage) in an id3v2, or it looks at id3v1 1st.  Funny that none of this seems to matter in MTP mode.  Yes tagging is a royal pain.  Just when you think they’re all fixed, one gets corrupted again.  Most people that think they have corrupt mp3s probably just have corrupt tag info.

If you thinks all that’s bad, just try writing a VB program that looks at mp3 tags!  Cut SanDisk some slack on this one, programming for mp3 tags (and the possible lack of them) is a major pain!  At least they continue to work on the firmware, although I’m sure MTP mode is first priority.

this doesnt apply to me… i always have both 3v1 and 3v2 filled and identical.

still buggy but fixable so far.
as long as firmware is sposed to be a concern, i really like the fm record for talk shows, i still want mp3 fm record opt.  how much would licensing cost sandisk anyway…i might pay extra for it.

Mine didn’t play on other players I don’t think.  It must have been an aborted download or something that I forgot to delete.

Try upgrade it to the newest firmware v1.01.18.  This version has the option to select MSC mode under Settings instead of the back door.  Maybe this new firmware might fix the problem for you.