Not enough room for music DB, can't proceed

I loaded music on my new 4gb clip (3.45gb of music) and when I disconnected it from the computer, it sat for a long time refreshing the database. No progress was being made, so, I assumed it was hung. Finally, I held the on switch to reset it and now, when you turn it on, it says not enough room to refresh the music db. I reconnected it to the computer and it again flashes that message and turns off. It won’t come on to manipulate anything. I tried to hold the on switch but it just displays the message and turns off. The reset doesn’t seem to be taking place. As it stands, my clip is DEAD!

Please help.

Brad. 

You should have read the manual to know the difference between MSC and MTP

When you loaded your music under MSC mode, it will be faster to transfer your music but takes longer to refresh DB…so be patient and wait for it to finish.  Anyway, here is the solution:

1.  Slide the power button up and hold for 20 seconds to do hard reset 

2.  Slide button back into “Hold” mode

3.  Press-n-hold the center button and keep it there while plugging in your computer

4.  Wait until the device actually connected before releasing it

5.  Then, delete 30MB of space on the device so it has room to build the database

6.  After deleting about 30MB of files, unplug from PC and wait for it to refresh DB and you should be done. 

First of all, I did read the manual. I allowed the player several minutes to rebuild the DB. The progress bar never changed. It was hung. I had already configured the USB setting to use MSC, so, it should have at least mounted to allow me to delete some files. After further research of the MANY people who are having this same problem, I did the “press the center button” trick (which I couldn’t find in the manual) to mount the player in MSC mode, which worked. I then proceeded to delete 500 mb of songs and try again. It hung in the same fashion. Understand that when it hangs, the reset does nothing.

After 2-3 hours of research and attempts to resolve the problem, I found a reference to issues associated with deleting files from the Clip and that these would be solved with a newer version of the firmware. I had upgraded to the .20a release and decided to upgrade to the .29 release. I doing this, it hung up doing the firmware upgrade. Again, no reset, no progress, dead clip.

Finally, I found another thread where someone had a “dead” clip and they were told to reformat it. I did this, installed the latest version of the firmware, and my clip was brought back to life. Since then, I have downloaded about 3.5 gb of music in 3 different copies (just in case), but I have not deleted any files yet. 

 Is there a formula for overhead memory required for the Clip to manage the music files? Does it make a difference if you copy individual files or folders that contain an album worth of music? Is is safe no to delete files?

Thanks for responding to my question. I hope my experience helps someone else. 

Sometimes, the device can hang up on the database refresh, from a bad file, an offending ID3 tag, or other assorted data issues.  In every case I’ve seen, the Format is the Nuclear Option, clearing up the device for a fresh reload.

Database refresh “hangs” have been addressed progressively with each firmware revision, as character and file glitches have been discovered, so remember that having the latest firmware is a good idea.  Between the 20 and 29 builds, the Clip is quite stable.

There’s one other option, if you wish to try holding the current music on the device, rather than a format, which you can always resort to: the database table itself.  This is the mtable.sys file in the root directory of the Clip, and it’s seen while in MSC mode.

This file holds the results of the “database refresh” done each time files are transferred.  If there’s a problem in this file, the Clip appends new data to it without rewriting the entire file, to save time.  I have found that deleting this file will force the Clip to automatically build a new file from scratch upon disconnect.

Sometimes, simply forcing the Clip to rebuild the mtable.sys file works wonders!

Bob  :smileyvery-happy:

Thanks for the help. I will keep this in mind.

I have ran into the same problem, except the steps to resolve are not working.  Well they work up to the point of actually being able to access the device in windows, which recognizes it as a USB device but that is all, and I cannot access the file structure to delete anything.  Help?

So, can you see the device in My Computer / Windows explorer?

To delete the mtable.sys file as listed above, you must be in MSC mode. 

If your clip isn’t recognized in Explorer, let’s try to switch to MSC mode, by navigating on the Clip to Settings > USB Mode > MSC.  An alternate, manual method of MSC mode is also available.  Start with the Clip turned off.  Slide the power switch to the HOLD or lock position (orange showing) and hold the center button down while connecting to the USB port.

Keep the center button pressed while connecting, until the PC seees the Clip in My Computer.  It should only take a few seconds.

Did you load your music in MSC or MTP mode?  Please note that files transferred in one USB mode will not be visible while in the alternate mode.

Bob  :smileyvery-happy:

Hi Bob,  I appreciate the help.  Let me explain a bit better what I have tried.

The clip is off

Set the clip to the “hold” setting on the manual slider.

While holding the middle button on the face, I connect the clip via USB.

The clip powers on, and immediately complains about lack of space.  This goes a way about a second later to be replaced with the Connected screen.

I continue holding the middle button until windows notices there is a USB device connected.  I let the button go.

The USB device is not recognized as a Sansa device as it had up to this point.  Windows thinks it is just a generic USB storage device and lists the drive as Removable Disk F:

Attempts to interact with the USB device are met with a format prompt, which errors out no matter what you do.

I cannot remember what I had set the data transfer mode to, I want to say MSC mode but cannot say with certainty.

At this point I am thinking the Clip is bricked which sucks because I loved that little thing and don’t have the money to replace it right now.  

Message Edited by runlevelfour on 08-22-2008 03:08 PM

Hi runlevelfour,

Here is something you can you.  Repeat the same step as you did earlier to make the device connect as a removable disk.  Now, once it’s connect as a removable disk (i.e. drive G), then go into DOS mode on your windows by pressing Win + R or press on “Start > Run” and then type in cmd to go into DOS mode.  Once, you have open up the DOS windows, please type this in to format the device completely:

format g: /fs:fat /a:32k /y

if your drive is different than g, just change it.  Once you’ve finished the formatting, unplug from PC & see if it will fix your problem 

An update on my experience. Once I updated to the new firmware, I have deleted and copied files from a Mac twice and had no problem with building the database. It seems to be working just fine and is a good unit. One other possible option for the forced mount is to first hold the on switch to ON for 10 seconds, then move it to hold and continue the process. I also noted that I had to be careful to press only the center button as if any other buttons are pressed, it doesn’t work.

Hey guys.  Tried the format solution and received this error from the CLI

 The type of the file system is RAW

 The new file system is FAT.

 Verifying 0M

 Cannot determine the number of sectors on this volume.

I have tried both holding power on for 10 seconds before the rest and it still does the same thing.  I am really thinking this thing is hosed.

If you have a 2GB Clip (maximum), FAT is the scheme of choice.  The message you are receiving is a confirmation of a messed up volume.  If you opt for FAT32, select 32KB allocation for the cluster size, as Windows likes wee 4KB clusters.

Once the Sansa boots after formatting, go to Stystem Settings > Format > Yes and let your wee Clip optimize the flash memory automatically.

Bob  :smileyvery-happy: