Not enough space for Music DB (Liar!)

I had my Sansa Clip 4GB connected to my MacBook Pro to charge. I needed to take my laptop somewhere, so I went into the Finder and clicked the Sansa’s eject icon. It didn’t unmount. I clicked again. I switched to other finder windows and clicked it there. I went into the Terminal and typed ‘umount /Volumes/SANSA\ CLIP’ fer crissake (it froze the Terminal window). Finally, after about three minutes, I went ahead and yanked the USB cable, cursed at the Finder when it politely reminded me to unmount disks before ejecting them, and went about my way. Yeah, I know, I broke a cardinal rule, but I didn’t have all day to wait for the Finder to give me my disk back.

I came back to my Clip later today and turned it on. Upon startup, the SanDisk logo shows for about 30 seconds, then I get the “Not enough space for Music DB. Please free up 30MB.” message. (Wow, the database really requires that much space?)

The thing is, I didn’t add (or remove) any files when I had my Sansa connected. (I did change some ID3 tags, though.) So I highly doubt it’s been suddenly filled up, unless the OS was putting garbage or something on it. (That would explain why it wouldn’t let me unmount it, I suppose.)

So I just mount it again and clean up the disk, right? Nope. When connecting, it does that same logo-then-error-message routine. If it sits on the error message for a minute or two, it eventually comes to the Connected screen, but it still never mounts in the Finder. And yes, I did try the hold-switch-and-press-center-button thing – didn’t seem to change anything.

Any ideas, folks? I really want my Clip back. 

Message Edited by Albright on 06-24-2008 08:07 PM

God, that Spell Checker pop-up thing is annoying.

Okay, I checked out the console as the device is connected. Here’s what it says:

Jun 24 20:22:44 Monster kernel[0]: USBF: 147.258 AppleUSBEHCI[0x3b5e000]::Found a transaction which hasn’t moved in 5 seconds on bus 0xfd, timing out! (Addr: 0, EP: 0)

Jun 24 20:22:50 Monster kernel[0]: USBF: 153.258 AppleUSBEHCI[0x3b5e000]::Found a transaction which hasn’t moved in 5 seconds on bus 0xfd, timing out! (Addr: 0, EP: 0)

Jun 24 20:22:56 Monster kernel[0]: USBF: 159.259 AppleUSBEHCI[0x3b5e000]::Found a transaction which hasn’t moved in 5 seconds on bus 0xfd, timing out! (Addr: 0, EP: 0)

(the above message repeated about a dozen more times with different USBF numbers…)

Jun 24 20:23:26 Monster kernel[0]: USBF: 189.294 AppleUSBEHCI[0x3b5e000]::UIMCreateControlTransfer - allocateTDs returned error e00002e2

(and the above message repeated three times)…

Jun 24 20:23:56 Monster kernel[0]: USBF: 219.633 [0x3d07e00] The IOUSBFamily is having trouble enumerating a USB device that has been plugged in.  It will keep retrying.  (Port 1 of hub @ location: 0xfd000000)

Jun 24 20:24:03 Monster kernel[0]: USBF: 226.263 AppleUSBEHCI[0x3b5e000]::Found a transaction which hasn’t moved in 5 seconds on bus 0xfd, timing out! (Addr: 0, EP: 0)

Jun 24 20:24:09 Monster kernel[0]: USBF: 232.263 AppleUSBEHCI[0x3b5e000]::Found a transaction which hasn’t moved in 5 seconds on bus 0xfd, timing out! (Addr: 0, EP: 0)

Jun 24 20:24:14 Monster kernel[0]: USBF: 237.749 [0x3d07e00] The IOUSBFamily was not able to enumerate a device.

Ominous. I tried Googling the message in that last part, and found some not-so-promising things like this page. On the other hand, others said it would fix itself after merely a restart, but it wasn’t that easy for me…

I guess I can try plugging it in to one of the Windows boxes at work, but until then… Is there a deeper reset than just the normal reset on this thing? I don’t really care if I frag my loaded music at this point; it’s all backed up.

Thanks for any help you can provide. 

There is no “deep reset” on the Clip. The equivalent is to use a computer to format the player. 

Go to MSC mode before connecting to a Mac.

If you can’t get to the Setting menu to change USB Mode to MSC, connect in Forced MSC mode.

To Connect in Force MSC mode:

  • Turn off the Clip.
  • Slide the Power switch to the Hold position.
  • Press and hold the Select (center) button
  • Connect the Clip to the Mac via the USB cable.
  • When the Clip turns itself on, let the button go.

At this point I must tell you I am Mac challenged. On a Windows machine, the next step would be to Format the Clip as a FAT32 file system. I am sure the Mac can do the same thing, but I do not know how to step through it.

After the format, eject the player, and see if it will start up normally.

Message Edited by Tweet on 06-24-2008 11:55 PM

Message Edited by Tweet on 06-24-2008 11:57 PM

Thanks, but as I said in my original post, I already tried the hold-switch-center-button thing. It doesn’t change anything. The Clip seems to be miscommunicating with the Mac at a deeper level.

Hmm, interesting…

About twenty minutes ago, I tried to mount the Clip on my Mac again. When it didn’t work, I ignored it and went about my business. But then, just a few moments ago, a window came up saying something like “The inserted disk could not be recognized. Do you want to format it?” Clicking “Format” started up Disk Utility, where I was able to format the Sansa as a FAT32 disk, after which it mounted in the Finder as normal. I could then unmount it. Going to Settings > Format on the Sansa gave me the directory structure back. My Clip is working as normal again! Looks like I just needed to wait something out.

Mac magic

or a poor connection.

If it happens again try another computer to see if the problem follows the player or stays with the computer.

Message Edited by Tweet on 06-25-2008 10:21 PM

Message Edited by Tweet on 06-25-2008 10:22 PM

Yup worked- now time to dig through my music DB -.-

I fixed this problem on my 1gb Clip using a Mac computer:

Working on the assumption that the problem was a corrupted file, here’s how I did it. I don’t know that all these steps are needed, for example, trashing the old content folders and creating new ones, but this is what I did, and success resulted:

Connect Clip to Mac

Click on Clip’s icon to open it.

Open up all content folders and drag songs, audiobooks, podcasts, etc. to trash and empty trash. (The idea is to get rid of the corrupt file, wherever it is.)

Drag all Clip system files to a new folder on the Mac desktop to copy them. This will include DID.bin, RES_INFO.SYS, SYS_CONF.SYS, version.sdk and WMPInfo.xml (That’s all that mine has, yours may have more or different ones. Basically, I copied everything that wasn’t a content folder.)

Don’t bother copying content folders AUDIBLE, AUDIOBOOKS, MUSIC, PODCASTS  and  RECORD. (Later, you’ll create new folders to replace these, to ensure that no corrupted file is reloaded to the Clip.)

Go to the Mac’s Utilities folder. Launch “Disk Utility.” Select Disk Utility’s “erase” function. On the left, where disks are listed, select the Clip. Click on the “Volume Format” dialog box and choose “MS-DOS filing system.”  (Don’t bother with any of the erase options, such as replacing all data with zeroes. Just do the basic erase.) Erase the Clip.

When erase is completed, drag system files that you earlier copied to the Mac back onto Clip icon.

Use “new folder” function to create new AUDIBLE, AUDIOBOOKS, MUSIC, PODCASTS and RECORD folders on the Clip.

Eject Clip from Mac and note whether the screen shows the Clip “refreshing database” normally. If it does, you’re in business.

Message Edited by myclipper on 01-29-2009 07:45 AM