Mac OSX HELP!

I received a SanDisk as a gift. Things were working great. I did not have internet at home on my PC, so I brought it to my Mac OSX comp here at work.

Here are my problems.

  1. I tried putting music and dragging it to the disk when it would show up on the screen. It worked fine until some songs wouldn’t start to copy to the disk. It would show that they were on there, but they weren’t.

  2. Eventually, I continued trying to copy the songs and they wouldn’t copy. Finally, my Mac didn’t recognize the SanDisk anymore after restarting and reconnecting. Now when I restart my SanDisk Clip, it says there is not enough space for Music DB and will not stay on.

  3. I understand that I have to possibly reformat, but I do not have any firmware/software on my Mac OSX to do that.

HELP?! This seems so impossible.

If you can get the Sansa Clip to mount as a drive on the Mac, then you can use Disk Utility to reformat the Sansa Clip.   Just select the Clip in the Disk Utility window and select the Erase tab.   For the format select “MS-DOS File System (FAT 16)”.   That should get you back to square one with the Clip and you can start copying music files to the MUSIC directory.  After you reformat the Clip, eject it from the Mac and let it reboot to make sure it’s okay.  Then you can start to copy music files again.

 One problem with dragging & dropping files with the Mac is that a bunch of extraneous files will be created on the Clip.   You can use a program called FinderCleaner (http://mac.softpedia.com/get/Utilities/FinderCleaner.shtml)  to get rid of all those extra files.

Good luck.

Great! It worked!

Thanks!

I see this post was almost 1.5 years ago but I have a clip and used disk utility to erase. Now when I try to turn it on, I get: Not enough space for Music DB. Please free 30 MB. Any suggestions? Thanks

this is weird because if you use the erase function in the disk utility, the files are completely erase.

try this one… instead of using erase, use ‘partition’. make sure that the format is “MS-DOS”.  if it is not available, go to ‘options’ and select MBR.

Thanks for replying. I went back to disk utility and chose partition, MS-DOS (fat). When I disconnected and tried to turn on, still same message appears: Not enough space for Music DB. Please free 30 MB. Any other suggestions. I might mention that this Sansa Clip is 1.5 years old, I got for the holidays year before last. I’ve just not used it until recently. I think I recently could not load music because it was in Mp4 format. Then I went to trying to reformat the clip and got it messed up. Is there anyway of restroring the original firmware?

I don’t think loading the original firmware will fix the issue.  Can you still access the menu of the device? if so, try to format it on the player itself

I cannot access menu. Everytime I try to turn it on, the message comes up then goes away to a blank screen.

When  you connect the Clip to the Mac and then look at what folders and files are on the Clip, what do you see?   You should also check to see how much free space is on the Clip.   It might also be worth checking to see if there are any invisible files on the Clip.  Please report back with what you find or if you need any other instructions.

I’m having this same exact problem.

Recently got a new iMac and followed the directions of the first few posts.  Went to Disk Utility and erased the Sansa Clip info.  Now I get that same message and the Clip just turns off.  I wish there were firmware updates compatible for mac.

Does anyone know what the hell I should do?  I’m on the verge of getting a iPod nano… 

My clip works perfectly fine with a mac right out of the box. Could it be you had some minor problem, and mis applied this ancient 3 yr old advice (maybe related to ancient firmware), and you turned it into a major problem? Maybe better if you described your exact problem rather than refer to confusing mishmash in this thread.