Music not showing up on clip or on my computer - but the space is being used up

Basically I loaded up my 4GB clip with ~3.5GB of music.  Worked great for a week.  I was charging the clip the other day, disconnected it and went to use it (the refreshing database thing went by much faster than usual).  However the clip showed that there was no music on the unit (song list was empty).  When I connected it back to my computer (auto detect and MSC mode - apple laptop), the music folder is also emtpy.  However the computer shows that only ~500Mb is free (i.e. 3.5GB is used up) and the clip itself independtly also shows that 500mb is free when you go to system info. 

So what happened?  My music is not showing up, but the space is used up so it must be there.  I tried reseting it using the 15sec power cycle thing, but that didn’t help.  I would rather not format it and would like to ideally recover my music.  Once I fix this, is there a way to prevent this from happening again?


Try deleting the mtable.sys file on the player. This will force the player to rebuild the database. See if this fixes the problem.

Did you change the music on the player since it last worked? If so, it sounds like your music might be in a format that the player doesn’t support. Are you sure the music is mp3 files? Another thought is that the music might be on the player in a different folder(If it is in the audiobooks or podcasts folder then the music won’t show up in the player’s database). I assume that you still have copies of the music on your computer. If so, format the player using its menu, change the player USB mode to msc(and keep it there), and reconnect the player to your computer and copy the music again to the player using drag and drop. see if this works.

Message Edited by JK98 on 11-22-2009 10:41 AM

If all he did was charge the thing, it’s unlikely his music switched folders or changed file type. If you have the copies of the music, you could try a reset, if that doesn’t work reformat and reload the music. Since you are using a mac, it only ever works in msc mode so confusion over mtp/msc isn’t an issue.

Im with JK A corrupt database is much more likely than your music just disappearing.

In MSC mode, you can use the chkdsk utility to repair the FAT on the Sansa as well, also available under Manage if you right click on My Computer.

Bob  :smileyvery-happy: