New Clip, File system (RAW) problem, please assist

Problem with Sansa Clip 8GB Black (v2 firmware):

Just got the clip, didn’t use it at all. First thing i did was to update its firmware to version 02.01.32, which i successfully did through sansa updater. Then i reconnected the player and it connected at MSC mode. So i started to copy some mp3s to the music folder.

Then for some reason during the copy i got a screen message on my clip saying something like recover File system. Now my player is in RAW mode, unformatted, and it shows on some disk utilities like a 4MB RAW disk. Tried to format it though windows XP SP3 but i get the message that windows are unable to format that disk. Tried chkdsk and it says that cant recover RAW File system disks.

The result is that my player is not opening at all, and the only thing i can do is to connected it in MSC mode on my PC. Please assist.

Thank you in advance.

Message Edited by th3m on 04-20-2009 02:26 PM

Has anybody experienced the same problem like me?

Does the Clip still work?  Can you get to the system settings menu?  If so, use the format command from there.

No it doesn’t work, can’t open it. Only thing that works is connect to PC though MSC mode.

Doesn’t look good then. I’d return it.

If you can connect to your computer, can you use your computer to reformat the Clip?  I’d also run chkdsk on it.

Unable to format it, and chkdsk is not working on RAW disks, it says. I think i am going to return it.

The only other thing I can think is, telephone SanDisk customer service, if you haven’t already.

If it’s RAW…you have to format it under DOS windows…here is how:

Click on Start > Run > type cmd & press Enter

On DOS screen, type this: Format “your device’s drive name, e.g. G:” /FS:FAT32 /A:32K

This should format your device properly and revive it.