Need Help with Sansa 4GB Fuse (Not Turning On)

My son just got a new Sansa 4GB Fuse about two weeks ago. It was working perfectly fine up until today. Now it is not turning on. I have read over some of the solution options to fix the problem but nothing is working. When I connected it to my PC I right clicked on properties and it showed that the battery is 71% charged so I know that the battery is not the problem. I have also tried resetting and connecting it to my PC in MSC mode. Oh and I should also mention that when I connect it to my PC my computer does recognize it and everything pops up like normal. The MP3 is just not turning on.

Any help or advice would be greatly appreciated.


Take it back and replace it. Or call 1-866-SANDISK. This shouldn’t happen.

You didn’t say; have you tried resetting it? Slide the spring-loaded power switch on the side up as if you are turning it on, but hold it there in the uppermost position for 20-30 seconds. Release and then see if sliding it up momentarily will start it up normally.