My Sansa fuze won't turn on

I have tried everysingle solution that I could find on the internet and still nothing seems to be working. I was using my Fuze in the morning, turned it off and when I tried to use it again later that day it wouldn’t turn on. It isn’t recognised by any of my computers or laptops and it won’t come up on the screen to show that it is being charged. Getting very frustrated with it as this is the first problem in over a year of owning it.

Unless you say exactly what “every single solution” you tried is, no one here will know what else to suggest. You’re likely to get duplicate suggestions for what you’ve already tried. :wink:

I’ve tried the holding the power button up for 15 seconds and for 30. The holding the left button as plugging in, holding the middle button while turning on. Putting it on hold and pushing the left button. Holding the home button while turning on. 

You may have been trying the proper steps, but your explanation is a little sketchy.  You need Hold engaged AND the left button AND connecting.

 Just to make sure:

Put it on Hold (while off). Open Windows Explorer (Computer or My Computer.) Plug the USB cord into the computer. Hold the << button and connect to the computer. It should pop up as two drives in Windows Explorer.

Maybe you already tried that, but humor me and try again. This generally works unless there is a hardware problem.

If nothing happens, you could have a bad cord. Or, of course, something worse could be going on. You can also call 1-866-SANDISK.

Yeah I have done that a few times and nothing seems to happen. My laptop picks it up so the cable is working. It’s just a removable disk that I can’t access and it says that I have to format it to read the files but when I try to format it says it cannot complete the format.

I might give that number a ring tonight thanks.

I have tried the solutions you provided.  It will only turn on for a sec and then turn back off.  It will not charge, nor play anymore.