My Sansa fuze + wont connect to the computer

I have not been able to find someone with this problem so I am starting this.

I have had my Sansa Fuze + for about 4 and a half months now. Suddenly it has stopped connecting to my computer. When i plug it into the computer, it will turn on, but it will not  say it is “connected” and will not charge. It will simply turn on as if I had pressed the button. When i plug it into the wall in my usb to wall adapter it charges, so I don’t think it is a problem with my sansa or the cord. 

My computer simply won’t even recognize anything is plugged in. I have tried all the USB ports on my computer (it is a PC) and I have tried other trouble shooting such as changing the connection type and updating practically everything. 

I really would like to put new songs on my sansa, so any help would be appreciated. 

You might try a different cable anyway. There are 4 pins; 2 for charging, 2 for data transfer. If just one wire is broken or pin is bent or disconnected, and that wire or pin is one of the two for data, it could still charge but not connect to your computer.

Also, have you had the opportunity to try it on a different computer?