fuze+ won't connect to my computer

My parents got me a Fuze+ for Christmas to replace my dead iPod. The first couple of months, it did everything it was supposed to, but now it does not connect to the computer. I have plugged the cord into every possible drive on the computer, I have tried it on my laptop, I have made sure the cord is connected on both ends, and nothing has happened. I don’t know what gives, but this is really frustrating considering that it has worked in the past.

Have you tried a different cord/cable?

i’ve used mine for ages and recently had my first major connection problem.

when i plugged it in all i got was a black screen, no charging screen and no connected screen would show.

I’m using windows 7 x64 and i tend to modify a lot of stuff, like killing services etc.

So i forgot what i did to screw it up but it was my fault, if i remember what i did ill edit my post.


i DID figure out how to fix the problem (atleast what i did worked for me)

basicly i went into the windows device manager and selected “Uninstall” device

then made sure to power off the fuze+ and then rebooted my computer

waited until it windows started and plugged the fuze+ back in and it detected the device

(it was showing nothing but the black screen) it then finished installing and then the device said connected

thats it lol

maybe this will help ?

This is what to do:

Turn off the player

Then Hold down the volume Down button until it says connected.

You should be able to connect to computer.

Perhaps don’t have any MTP drivers (included with Windows Media Player version 10 or higher)? The Sansa Fuze+ has three USB connection modes: MTP, MSC (that is, flashdrive mode), and Auto Detect. If your device is on Auto Detect, perhaps it was connecting in MSC mode. You can force it to connect in MSC mode by holding the Volume Down button while plugging the device in; do not release the button untill you see the “Connected” logo.

If this works for you, you can make this happen automatically (without holding any buttons) by going into Settings > USB Mode, and select MSC.

It’s probably worth noting MTP isn’t really needed unless you are transfering copy protected material to your device. Assuming you don’t have copy-protected materials, MSC is usually the simplest and the most reliable mode.