hi everyone…my sansa clip is turnin off…showin battery low…and gettin switched off…evem after charging it…its showin the same…wat can i do now…

Did you try a reset?  And how long are you charging it for?  Are you sure it’s charging?  You might want to try a different cable/port, or try charging via AC.

hi. um i was listening to my sansa clip and all of a sudden it turns off and wouldnt turn back on… i looked on the back of the manual and it told me to come to this website for help can anyone tell me what to do to get my sansa clip to turn back on please,?

Did you try a reset?

First, you can rule out whether your player is frozen, needing a reset, or if you have a genuine battery issue.

Grab that USB cable and plug in, preferably into an AC USB adaptor if you have one, since we’re first interested in an alternative source of power for the Sansa.  If the device powers up as soon as it’s plugged in, this is a good sign.  Watch the battery icon,and see if it is “rolling along” indicating that the device is charging.

If you are plugged in to a power source only, you can test the controls of teh Sansa to see if it responds normally.  If connected to a PC USB port, the control actions should be inhibited, and the display should show the Sansa as “connected”.

Now, unplug.  Does the display immediately go blank and the Sansa is shut down?  This means that the battery is either seriously depleted or there may be a battery / battery connection problem.

If the Sansa does not respond at all when plugged in to power, it may be frozen.  A note here: the Sansa is never really “off”, it’s hibernating.  Control of the charging operation is done by the device’s processor.  If frozen, it won’t wake up as power is applied.  Let’s perform a soft reset on the device.  For the Clip, slide the power switch UP and hold it in the ON position for 20 or more seconds (usually no more than 30, and it will often reset in as little as 10).  Release the switch, and try powering up normally; it should then start up.  With the new Clip, the power button is held down for the same roughly 20-second period.

Bob  :smileyvery-happy:

The last post didn’t resolve my problem.

When I plug the clip into the power adaptor it says

Battery Low followed a couple of seconds later  by Shut Off - then nothing.  Same result trying to power via a laptop USB port

Interestingly, the blue light on the power adaptor goes off at this point too.

Any ideas?


Sometimes the power level can get so low that the player can’t charge normally.  A sometimes solution is to leave it plugged in for 2+ days–the trickle-charge can get the power level back up so that you can turn the player on again (and then fully charge it, if needed).

Thanks, plugging in now.

Sorry - plugged in for three days - still not working - any other ideas?

Needless to say, some sort of charging issue.

I would telephone SanDisk Customer Service about this.  In the U.S.:  1-866-SANDISK (726-3475).  And other SanDisk contact information:

And by any chance, are you still within the warranty period?  (1 year U.S., 2 years EU.)  SanDisk is good about warranty replacements. 

What I do when that happens to me is wait anywhere from 20 min. to a few hours, then try turning it on again. It’s happened to me quite a few times and that always seems to work. It’s more than likely just a short in the player.