My Sansa Clip has become Read-Only

I got a Sansa Clip 2GB last month, and I’ve run into a problem, it is now read only, not just the files, settings, EVERYTHING.

I was transfering songs the other day and it hung. I left it for ages and finally just shut down. Anyway, after that, I noticed that it was always “Refreshing Database” on every start up, I also noted the three new songs I added weren’t there. Tried it again, looked like it worked this time, but it didn’t. Tried removing some songs, appears to work, but it doesn’t.

Tried formatting from the clip, this appears to work, (and rather quickly) but it doesn’t. It shows no files, artists, anything, but as soon as you restart they are all back just as it was on the last restart. Interesting to note, that if you go to system, after the format, the free space does not change, even though it says it’s empty.

I tried formatting from Windows, that doesn’t work either. Windows just returns an error. I tried chkdsk, it says “0 percent” for a bit, then just drops back to the command line without error and while the drive letter is still there, it shows no folders or anything at all as if it’s reset.  If I look at the device, prior to trying to format it, all the folders are there (Music, Audiobooks, etc), but they are all empty (even when showing hidden files)

Any attempt to delete or copy a file to it, resets the connection and the clip is gone or it simply shows no files or folders. 

So I fire up linux and gparted, any attempt to format the partition returns an error stating something about a FAT mismatch, if I try to delete the partition, it says it works, but as soon as it refreshes the device list, it’s still there.

I even tried deleteing every file on the clip manually and all I’ve got is a sore thumb. Voice recording doesn’t work either, says it does, but there always 0 seconds.

Mine came with the newest firmware and the updater won’t allow me to install the same version, any suggestions? 

I doubt that this will help, but try a system re-set:  on switch in the uppermost position for 10-15 seconds.

Perhaps also try to re-apply the latest firmware manually.  See the firmware update sticky thread at the top of the forum for the firmware and the instructions.  I then would also try to reformat.

Perhaps this might help–good luck!

Should have mentioned I tried the reset many times, but I’ll try to force the firmware update. thanks

No dice. When I try and copy it it to the Sansa, I get an error. “Cannot copy m300a: Data error (cyclic redundancy check)”. I’m gonna guess this is bricked.

Yep sounds like it’s bricked. Unlucky man, this happened to me with a 4gb microSDHC card but I got it replaced after a week.

I was afraid of that. The thing that boggles me is how it in all other aspects works fine. I would imagine there’s not a ton of ram in the thing, but every song edit, rating, setting change, etc is kept until it restarts.

As a for instance, I was able to rename folders in Windows, I get an error, but it still does it. So if I change Music to **bleep**, it will reflect that, even if I refresh, or dir it from the command prompt, but if I make another change (or disconnect), **bleep** becomes Music again.

If I look at the device with MTP, it shows one folder, Music (which is empty) and seven files with no name and zero bytes, gonna assume those are the other folders. 

Lol, btw, I’m surprised that word is bleeped, that word would only be mildly eye-raising even in the 1950s, but I digress.

Sorry the fixes didn’t work–but warranty replacement is a good thing.  :wink:

Hi, I have exactly the same problem. I’ve also tried to format device from windows/linux - unsuccefully. I’ve tried everything. I don’t know what else to do… How did you solve this problem. Anybody did?

This may sound strange…but before you throw in the towel…can you try using  Another Operating

System…???  you mention Linux…I wonder if a Windows XP  system would reveal more info as

to the problem. Maybe a friend with a laptop that Win-Xp or Media Edition 2002 with SVC PK 2.


I bought the extended warranty on mine just in case of stuff like this…

I don’t think, that use of another OS can solve the problem,
but I tried. It has the same result, so i tooked my SansaClip to the servis. Now I already have the new one, bud I still don’t know how to fix this problem. Thx for help

I solved the read-only-problem running fsck on Linux.

In details:

  1. Unplug the Sansa Clip. Run lsblk to see what block devices you have.
  2. Plug in the Sansa Clip. Ran lsblk, and notice the new device. it was /dev/sdb in my case, lets assume you have the same.
  3. Run the checker sudo fsck /dev/sdb.

In my case the checker found and cleaned so called dirty bit. The Sansa Clip works again.