Format Does Nothing: Virus?

Ok, my 2GB Clip just now stopped working. I just added songs to it thru Rhapsody and it was working b4 i did this. After it added the songs i unplugged and noticed that it was frozen on ‘Disconnected’ message for a while but then it showed the ‘Refreshing Database’ message so i thought nothing was wrong.

Then i go to play a song and it freezes for a minute and then says that i need to update track license. So i go and try to update my clip but it says there are no songs in it but the memory is full.

So i figured it crapped on itself and decided to format it. I looked at the songs list and they were deleted but when i turned it off then back on ALL the songs were back.

I tried formatting it thru Rhapsody but the same thing happened.

So then i go into the Clip thru ‘My Computer’ to see if i can delete them that way, but all the things in the music folder were unknown objects and i couldnt delete them, a message popped up saying that the device stopped working or was disconnected when i tried deleting them. 

Is this a virus or did my Clip just die?

Message Edited by Asher on 10-08-2009 11:21 PM

Is it possible, perhaps, to reformat via your computer?

Nope. Tried that too. After it does the ‘Refreshing Database’ thing everything comes back. I also tried to update the firmware to see if that would do anything but it wont, saying there is no space left on disk. Also it seems to do everything really slowly.

Message Edited by Asher on 10-09-2009 02:40 PM

Read FAQ #3

  1. Force MSC mode.

  2. Run checkdisk from windows.

  3. Format as FAT32 in windows.

  4. Reload firmware manually.

  5. Format from player settings menu.

  6. OK? - Great!

  7. Not OK? - Return player and buy a Sony.

Im done with it, ive tried most of the things u mentioned with no luck. Gonna send it in 4 a new one tuesday. Hooray 4 warranty!