My Fuze stopped working completely

Hello everyone,

I just bought the player, charged the battery, filled the machine with some music /using WinAmp/ and then started to play it. Was very happy with the machine till I turned it down and Fuze said Good Bye and this was the very last message I got from it. It refuses to open and when I plug it to PC, it is instead of Fuze recognizing it as “UNDEF storage USB device”. It doesnt charge any more and refuse to work at all. It acts the same with my Vista computer as well as with the older XP one.

What I am supposed to do? Probably bring it back to the retailer, I guess?.. No way how to fix it?

Thank you for your help,


1 Like

If the retailer is local then taking it back would be the simplest thing to do.

1 Like

In fact it isn’t, I have to send it back by post, so it will take some time and that’s why I prefered to ask here first.

1 Like

Phone Sandisk Support, it the best thing you can do in your situation.

Have you tried a reset from the device?  Hold the power switch in the ON position for 10 seconds, release, then try starting up as usual.

Bob  :smileyvery-happy: 

Yes, and nothing has changed… :cry:

At this point it wouldn’t hurt to try formatting the device and see if it responds properly, on the chance that it’s simply garbage data.

I would try reinstalling the firmware once via the firmware thread.  Remember that for repairs, the Sansa Updater won’t reload a copy of the same firmware build, so do it manually. Follow the firmware 1.01.11 thread directions.  Be sure to unzip the firmware file before transferring to the root directory!

This will eliminate the two biggest possibilities: data corruption, or firmware corruption. 

With a little luck, you’ll have a live Fuze.  If it’s a fizzle, time to exchange it.

I’ll keep my fingers crossed.  Post here if you run into any snags!

Bob  :smileyvery-happy: 

Yes, I was already reading about that, but I in fact was not able to access the device in any way, Windows asked allways to insert disc (like there was not the drive, although it appeared there as a volume - actually two of them -). I already contacted retailer and sent him back, so I hope they will replace it or fix and it won’t happen again…

Thank you very much for your support, anyway. If there was anything wrong, I know where to ask for advices.

Thanks so much, I had a similar problem to the user at the beginning of this forum, and your advice worked! I was about to curse everything Sansa.


This actually worked GREAT for me. I was in the middle of listening to an exciting audio book, almost at the end, when my Fuze would not start, recharge, or be recognized by my PC. Thank you so much for the simple fix!!


hi, yeh mine just shut down at the end of a song and wouldnt do anything, not even charge or be recognized by the computer when plugged in. tried the ten second thing with the on/off button and it seems to be alright now… thanks! :wink:

I own three of these (don’t ask), and this same thing has happpened to two of them!  I tried all the above answers except sending it back, but I really would rather them fixed because the computer I used to put on the music crashed along with 8 days worth of songs…:cry:  any help?

Reset worked for me.  Thanks!

If nothing else…one thing I can say about the Fuze having 3 in my household, I was glad I spent the extra few dollars to buy at my local retailer as opposed to  purchasing a refurb or on ebay etc…

Bestbuy has exchanged 2 of ours now with no questions asked…very nice when you have a Fuze that’s DOA…

Thank you very much for the tip as it worked with my Sansa Fuse when it suddenly seemed to go dead. 

Just wanted to thank you. My Fuze also stopped charging and wasn’t recognized by my computer and I thought it was dead. I tried switching USB mode to MSC and it didn’t solve the problem. Then I reset it - didn’t solve the problem. Then I reformatted it - no better. But then I followed your link and updated the firmware and it seems to be fine now - computer recognized it and it is charging. Thank you very, very much.