Looaads of problems with my 8GB Fuze

Hi, I used to love my Fuze now I hate it, all problems started this week. 


  1. Randomly freezes when refreshing database

  2. Randomly freezes when listening to radio (keeps playing just can’t change station or volume)

  3. Randomly freezes when navigating menus (does it everytime now just a matter of when always within 30secs of turning on)

  4. Randomly freezes on Welcome Screen (flower logo thing)

  5. Will not charge (starts charging animation then freezes)

  6. Will not connect to PC (freezes on ‘connected’ screen. Sometimes will connect I can see it in My Computer but will disappear almost instantly or if I try to access it through my computer)

  7. Sometimes will not turn on (removing and replacing SDcard used to make it start that doesn’t work anymore)

What I have done:

  1. Removed MicroSDHC

  2. Formatted Fuze from within system settings on fuze

  3. Downloaded and installed new firmware (x.26)

All problems persist, in fact its now worse

I cannot format it from my PC as I can’t see it. Changing between MSC and MTP does nothing. 

Please any help I need this player to get me through my workday. Is it borked?

Have you tried giving the player a long charge with a wall charger? Will it charge completely that way? If that works, then remove the card and connect the player to the pc in MSC mode and reload the firmware.

Sounds like it’s time for a call to SanDisk Tech Support.

For an RMA (Return Merchadise Authorization) if nothing else.

Hi, sorry for the late reply I ended up buying a usb wall charger. It turns on when I connect it but stays at the flower logo screen no charge icon, is that normal? I left it on all night it appeared to have worked, said it charged to 100% but still got all the problems. PC still won’t recognise it MSC and MTP modes. Yep I thin kI need to be calling sansa support. bugger i really liked this player too.