My Connection Problems, Solved!

I had a problem.  I was about to return my sansa clip to the store in anger.

Sometimes it would connect, sometimes it would not.  Mostly not.

Ocassionaly it would work great, but usually it would show up as an unknown usb device in device manager.  Or just not connect at all.

I read and read the internet and these forums.

I tried putting it into the two different usb modes.

I tried updating my firmware to .29

I tried the thing where you put it into hold and then press the middle button.

I installed windows media player 11.

I tried different usb ports and removing all other usb devices.

I installed some wierd MT? driver pack from microsoft.com

I tried restarting my computer.

I tried uninstalling the unknown device.

These things didn’t really help, they would connect it after a half our of fiddling, doing these same things over and over again. 

I did solve it, and I am happily using my clip as we speak.

You know what the problem was?

Sandisk shipped me a bad cable.

I tried it with the cable for my camera and now it comes right up in explorer everytime.

I tried the cable that sandisk sent me with my camera and It doesn’t work at all. 

So if you are like I was and having trouble getting your sansa clip to connect reliably. 

Try a different cable.

It’s not really worth it to get a RMA for a cable I don’t think. I don’t want to go through the lenghty time it would take to prove to the person on the other end of the phone that a USB calbe is faulty.  And the shipping cost would be more then the cable is worth to replace via ebay.

Overall, I really do like the player.   It is superior to all others I have tried in the same category.  (Ipod Shuffle, Ipod nano, Zen Stone, and the RCA Sport)

Likely, SanDisk would simply ship you a new cable with little question, and may not require return of the old.  I’d do it–nice to have an extra USB cable around.  Simply requires an email or tollfree phone call (at least in the U.S.).

I’ll give it a try, nothing to loose.