My Clip Completely Stopped Working. Help?!

I was listening to my clip yesterday, and midst a song it turned off. I reached down, and tried to turn it back on various times, but it wasn’t doing anything. I thought it was because it ran out of battery, but when I plugged it in the computer to charge it, nothing happened either. You know, usually the SanDisk screen pops up, right? But on mine, nothing happened. At. All. I even tried switching USB cords (my brother has one too.), USB ports, and computers, but it’s still unresponsive. Any ideas or suggestions anyone?

Please help!

Hopefully this simple solution will do the trick: hold the power switch in the ON position for 10-15 seconds, release the switch, then power up as usual.

Every now and again, a reset does the job.

Bob  :smileyvery-happy:

I’ve tried this tip, but nothing changes… What can I do Bob ?



If your Clip won’t respond to holding the power button on 10-15 seconds, then restart; or if it won’t respond when connecting to the PC normally, it might have failed.

I would contact SanDisk at 1-866-SANDISK with your concern, as it’s still under warranty.  They’re most helpful.

Bob  :wink:

I’ve bought this one at the middle of January 08 by the website “Pixmania”.

I’m living in Belgium (Europa).

I’m waiting about your answer about the procedure to do.

Than you very much Bob,


No problem.  Here is the contact page for SanDisk.  They should be able to assist you!!

Bob  :smileyvery-happy: