Music on e280 but not showing in WMP

Hi, All…

I’m new to the MP3 world and admit I need alot of education.  I’ve learned alot by reading the forum, the Web, and the Sandisk videos and appreciate all the feedback you’ve all provided to us newbies.  I have an issue I don’t understand and would appreciate some help.  My resources:  e280; WMP 11, .18A firmware, Win XP Pro.  As of three hours ago, everything worked fine.  A month ago, I loaded about 500 songs and it’s been working great.  I was ripping CDs to my lib earlier, about 10 of them.  They transferred to my lib just fine.  I connected my Sansa and in WMP I could see my old music was there.   I fooled around, played some music, did some editting.  I did not sync the files I added tonight.   I disconnected my Sansa to check the USB mode, plugged it back in to do the syncing, and in WMP, it now says the device is empty.  It’s wrong!!  I can see all the music in Windows Explorer.  I can see and hear the music on my Sansa.  It will absolutely not show up under e280 in WMP.  I am using manual mode as I do not want all the library files on the Sansa.   What am I doing wrong?

Let me make sure I understand how this works:  The process of syncing does more than simply show a list of music here and there.  It actually does the copying of files from the PC to the Sansa or from the Sansa to the PC.  Am I understanding this correctly? 

  • Is there a specific sequence with regard to connecting the Sansa and opening WMP?  Am I doing that wrong? 
  • Could I have disconnected it incorrectly and damaged files?  When I disconnect, I go to my systray, click on the USB icon, choose “stop device”, and select Mass Storage.  Is this correct?

After I ‘played’, the Sansa, insisted on ‘Writing’, even tho I had not transferred anything.  It did this repeatedly, every time I tried to connect after that.  Also, I’m getting a message that says ‘Refreshing Databases’ every time I disconnect now.  Is this a function of .18A?

One thing that has been happening tonight which I’ve not seen before is that my Adobe Photo Elements 4.0 keeps popping up when I connect the Sansa.  I exit it quickly, but that may be an issue.  

Perhaps the best thing to do would be to reformat and start over, but I’d like to know what I did wrong so I don’t do it again.

I really love this little guy!!  :smileyvery-happy:  Thanks for whatever light you can shed on this.  It would be greatly appreciated!

Irene in Seattle

Hello Irenejd, Welcome to the forums…

Sounds like somehow the player has been changed over to MSC mode.  Please change it back to MTP mode by the following suggestion:

Settings > USB Mode > MTP

Hope that helps

  1. There is no specific sequence to connecting the device and opening WMP. Any order will do just fine.
  2. Based on your explaination, you seem to be disconnecting it just fine. In MTP/Plays for sure mode you dont have to do this.
  3. It will refresh the database whenever there is a MicroSD card in it, or when you have changed any files on the player itself. It might have changed and you dont even know it.
  4. If you have pictures on the player, that might be why that adobe program keeps opening up. This is a setting you can change on your computer.

I am on WinXP, WMP11 and work in MTP/Plays for sure mode. My stuff shows up in WMP11 just fine. I can even search for the file I need to find by artist/album/genre on the left hand side.

I have the same problem with WMP11 and tried hooking it to a computer with WMP10, and all the songs on the e260 show. Does that mean we need to roll our machines back to WMP10 or is Sandisk going to do something so make WMP11 work too?

did you tranfer your files in mtp or msc mode? that might make all the difference.

 I dont think this is something SanDisk did to make it change. If it worked in 10, then windows changed something in wmp11

Thank you all…Enigma, Housecall55, and Baggage!   All I can say is, Well, DUH!!!  It was in MSC mode.  I think I changed it doing something I saw in the vid.  Once I changed it back to MTP, everything appeared in my e280.  I’ll try syncing now, and getting some album art correct.

Housecall55…were you able to see  yours successfully?

Thank you all again.  It’s so nice that you’re here!   I hope I can pay it forward.


Hi, Me too I have the same problem on my Sansa e250.  I don’t see my music in window media player. WMP say No media item on player.  I try to put USB mode in MSC or MTP mode.  No changed.  My Sansa have 1 GIG of music on it.  When I go to Windows Explorer, I see all my files. 

If someone have idea of my problem, thanks.

I have the firmware 01.02.15A and my Sansa are in warranty.

Thanks again

Try updating to the newest firmware like the previous person before you and see what happens then.

I update the firmware.  I have the new one, but Window Media Player say to me that it have no files on the Sansa.  If is not the firmware, what did happen.  Yesterday, my Sansa work fine and I do nothing special.  Thanks