Files available but cannot sync

e280 version 1. - latest version of firmware as of 5/10/10

Windows XP Home

Windows Media Player 11

I have tried many of the idea’s posted, but am getting frustrated as I cannot resolve the following.

I replaced my old PC with a newer one.  I tried to connect my e280 and upload a new playlist/songs.

In MSC Mode,  the WMP will connect and allow me to upload the playlist/music.  But when I unplug,  the e280 does a reboot and rebuilds the database.  When it comes back on the data recently uploaded does not appear.

Also,  If I try to see the music on the player via WMP, it informs me that there is no music on the device, yet the status display informs me that I have 1.7GB avialable (8.0GB device)

However, I can see the music via windows explorer and when I unplug the device,  I can play the music. Couple of notes,  the music, picture and system file are “hidden” in windows explorer.  I can drag and drop music via windows explorer after I change the folder settings.  These files are then available for playing. But when I unplug,  it resets the folder settings back to hidden.

In MTP mode, the system just keeps trying to reinstall the driver.  I have deleted the drivers via the control panel as described from other posts,  but to no avail. 

Finally,  I tried to reformat using the Sansa format tool.  It starts and then tells me that the drive cannot be formatted and that I should contact Sansa Support for a replacement.  

Any insight would be appreciated. I use this thing about 20 times a year.  I am really bummed as I just go into bike riding season and cannot upload new music…


A couple of things. In the v1, the Music folder is hidden, and reverts to hidden after rebooting even if you change the attribute.  It’s crazy, but that’s normal behavior. And your computer only sees music tranferred in one mode at a time, MSC or MTP. 

Are you sure the songs are tagged? Have you scrolled down the Album or Artist list to see if there’s an Unknown? Files that are not tagged in ID3v2.3 won’t be indexed by the database.  You can fix them with mp3tag. Under Tools/Options/Tags/Mpeg set Write to ID3v2.3 ISO-8859-1. Then navigate to the album folder, highlight all the files and Save. 

There’s also a possibility that the files that play in your computer, even if they say 01-song.wma,  are .wma pro or .wma lossless, which the Sansa won’t play. Look at them with the Gspot codec appliance.

WMP works better in MTP mode. You might try looking at for the MTP Porting Kit, and see if installing that helps. Or try rolling back and then reinstalling WMP 10 or 11. There are other suggestions in the link in my signature. 

Me, I just drag-and-drop albums in MSC mode.  (I have Windows set to Show hidden files and folders.) But if you’re hooked on WMP playlists, your best bet is to get MTP mode working and use that. WMP connects in MSC mode, but all the playlist functions work better in MTP. 

If you’re willing to format and start over, put it in MSC mode, right-click and Format to FAT32. And if that fails, try right-clicking on the Sansa, Properties, Tools, Error-Checking to see if it can fix what might be a corrupt file, then try Format again. 

 Make sure your music files are .mp3 or  basic .wma, drag them over, and see how it goes.