Mp3's on Clip not recognized on WinXP

I’ve had my 2gb click for almost a year.  I have all of my music on my win2k desktop.  So I just plug in the clip and dump mp3’s onto it and it works fine.  HOWEVER… I plugged the clip into my WinXP computer at work a few weeks ago, and none of the music I loaded onto it is showing.  It only shows the Mp3’s that were shipped w/ the player.  I thought this was a fluke, but now I’m traveling, and I’m on my WinXP laptop - same problem.  It recognizes the Sansa by name, even has a different little icon by it, but when I open it up, I see only “Data” and “Media” folders.  In the “Media” folder, the only Mp3’s I can see are the four that shipped with it.  Why is this happening? 

Your trusty Clip has Auto Detect turned on.

Go to Settings > USB Mode and select MSC.  Your music will appear again.  The Auto Detect function has a peek at the OS on the host computer, and connects in MTP if the PC has Windows XP and Windows Media Player 10 or above.  This combination supports the MTP protocol.

The original music loaded on the Clip was transferred in MTP mode.

Part of the MTP / MSC difference is that files transferred in one mode are not available while in the alternate mode, when viewed from the host computer side.  As long as your music has valid ID3 tags, the Clip will see all files regardless of transfer mode.

Bob  :smileyvery-happy:

I don’t have “USB Mode” in settings.  I looked at FAQ’s and followed this:

And restarted my computer and now it won’t recognize that I have the clip there AT ALL :-( 

Nevermind, I followed the directions here

To put the hold on and press the center button and it recognized it as a removable disk.  Then I could install the new firmware and *now* I have the “USB Mode” option in settings. 

Ah, you had the earliest firmware version, without the selectable USB mode.  Glad you have updated!  You’ll find that there are quite a few new and cool changes to the Clip.  Enjoy!

Bob  :smileyvery-happy: