Clip not recognized on PC in MTP mode

Hi all,

I have a Sansa 2.0G clip. I hardly ever update music on my clip but I went to do it a few months ago and couldn’t get it to recognize my clip. So after some searching I did a firmware upgrade to 01.01.32A. After that I could no longer see my music. I didn’t do any research, just assumed that the firmware upgrade wiped my hard drive. So I proceeded to copy some songs onto my clip, but was confused about the minimal space.

Shortly after I realized, that I probably had all my songs (originally) loaded MTP, but after the upgrade was switched to MSC and had loaded some songs in MSC mode. At any rate - I now REALLY want to move some songs around and seem to be unable to get my clip to be recognized in MTP mode.

I went to USB settings, picked MTP, but when I plug it in - nothing happens. I am not holding down any buttons on the clip when I plug it in.

I’ve tried to do some due diligence here by reading the user guide and searching the forums - but I can’t seem to find how to get my PC to recognize my clip in MTP mode.

Can someone help?



I’d try 2 things upfront:  a system reset (with the Clip off, hold the on switch uppermost for 15-20 seconds); and a reformat under the Clip’s Settings, which sometimes can help (note:  it will erase any content you have on the Clip).

By the way, you also have Windows XP with service pack 2 or above; and Windows Media Player 10 or above, right? 

Hi Miikerman,

Yes, I have XP Service Pack 2 and Windows Media Player 11

Sadly the system reset didn’t work. I’m super bummed to reformat and lose the music that I do have on there…but if I can’t get it to work any other way - I will do that. I’d love to copy over those files and then reformat - hehe…but there’s the problem isn’t it…I can’t see my files to copy over. argh :slight_smile:

Thanks for the advice!


Hey! woohoo…On another frustrated whim I did a search and found this gem:

It worked!!