Computer doesn't recognize in MTP mode

Hey guys,

I dont know why but my new computer doesn’t recognize my Sansa Clip+ in MTP

Neither with Frimware

It only recognize if I switch to MSC. between it suggest me to format it,

I tried to format with windows but it says " Windows was unable to format" 

And tried to format from the device… but it still suggestme to format it… 

The problem started 1 week ago, when I got my new computer… 

By they way, in my older computer the MTP worked as well

Thanks in advance !

Sorry for my typo :<

Do you have Windows Media Player 10 or above installed?  It’s needed for an MTP driver, although you also can get the driver from a Microsoft porting kit. 

Yes, I have Windows Media Players 12 (of Windows 7)

And what is that Porting Kit ? 

The Windows porting kit includes the driver needed for MTP play.  But if you have WMP 12, you’re already covered–you have it. 

I wonder if it might help to go to the device manager section of Win7, de-authorize the Clip drive, and then detatch and reattach the Clip, so that the computer sets up the connection anew. 


It works! really really thanks !!!

Great to hear!  What, actually, did it–going through the device manager and deauthorizing the Clip?  (I’ve never had to do it–perhaps posting a step guide here will help others.)

I just went to Device manager and Uninstalled the clip, than detatch and reattach the Clip… 

And thats it! it worked :slight_smile:

Cool.  Hopefully, this will help others.  Personally, I’ve never needed to uninstall the Clip with the device manager.