computer does not recognize my player

I have two Sansa Clips, a 2GB and a 4GB.  My computer does not recognize either device when I plug them in.  I can charge either player in MSC mode, but cannot download music from Rhapsody. 

Why can’t my computer recognize either device?  

I have Windows Media Player 11.

Thanks.  

If the device is recognized in MSC mode, the USB comm section of the Sansa is OK.

The problem is with WiMP, as MTP mode is a virtual mode supported by the player.  You can repair the MTP link by reinstalling WiMP, or upgrading from WiMP10 to WiMP11.

Manually connect in MTP mode: Settings > USB Mode > MTP.

Then go to the Device Manager via Control Panel > System > Hardware Tab > Device Manager.  Look for the wee yellow triangle of doom.  In MTP mode, the Sansa should show up under Portable Device.  Select Properties, then uninstall the device, then plug it in again after unplugging, and let Windows reinstall the driver.

I prefer to reboot the PC when working with drivers, then plug in again after the computer reboots.

You can try the “John Wayne” method, selecting “update driver”, and see what happens.

This should restore MTP for your Sansa, and then services like Rhapsody are again possible.

Bob  :smileyvery-happy:

Hello. Please Help!!! I just bought my sansa clip from an individual thru cragslist and I feel like I just bought a lemon. My computer doesn’t recognize at all that my sansa is plug in via usb port. My ports are all working fine but when I go to my computer, it doesn’t show up that i have a portable media player plugged in. It’s charging the battery of the device and that’s it. Is the firmware on this device ruined and did I just pay for a lemon? How can i get my windows xp to recognize this device???

First, don’t worry yet–you’re probably ok.  Second, do you have the Clip’s software requirements?  The Clip’s stated requirements are Windows XP SP2 or above, and Windows Media Player 10 or above.  Do you have that?

If you do, you should be able to connect your Clip.  If you don’t or can’t, try choosing to connect in USB “MSC” mode–it is more universal and has lesser requirements.  To do so, go under the Clip’s Settings/USB and choose MSC.  If you have older firmware on the Clip and don’t have that, force MSC mode by putting your Clip into hold (on switch all the way down) and then connect the Clip to your computer while holding the Clip’s center button down (and then upgrade to the latest firmware–see the sticky thread at the top of the forum–so that you can set the USB mode to MSC).

Othe possibilities:  try other USB ports, and other USB cables.

Hope this works; let us know–

Message Edited by Miikerman on 04-19-2009 06:19 PM