sansa clip 2G wont be recognized

When we plug in the sansa clip2G into the usb drive (any of them) it says unable to recognize the device unplug and try again. I have read some of the posts in here and nothing seemed to work yet. We have windows xp and we have windows media player 11 so if anyone can help … or is there a phone number to get a hold of an actual person in technical assistance that anyone knows of?

Have you tried different modes?  Clip has two modes: MTP and MSC…if you browse the settings > USB mode, you can select the Auto, MTP, MSC…try out different modes to see which one works for you. 

Or force an MSC connection:  Clip on hold, and press the center button down as you connect to your computer.

I have the same problem. I tried almost every sloution i found in the net and now i endet up here and asking for advice. i have WinXP, the newest wmp and still not working. the player is shown as “Unknown”. i tried everything in the Knowledgebase. still won´t work. maybe here somebody can help me :smiley:

mfg moschte