MP3 files skipping

Out of nowhere MP3 files on my SCZ started skipping. It started with soe podcasts I wanted to listen to, but all my music was fine. I decided to restore it to factory settings and format it. When I put my music back on it all started skipping like a record and it would just move onto the next song. I even bought a new Sansa Clip Zip and tried again, only to have the same problem. WMA files do not seem to be affected by this.

Does it help if you reapply the latest firmware? (See the firmware upgrade sticky thread at the top of this forum, for the firmware and easy-to-apply instructions.)

Just tried it. Didn’t seem to work. All the files play fine on my computer and such, but when put onto the player they skip.

What is the bit-rate of the files that the skipping occurs on? Too low (like on some podcasts) have been reported to cause this.

How would I figure out the bit rate?

Pause the song (top button)to stop the skipping, and press the down button. Select the track info and scroll down; the bit-rate will be displayed.

Or while connected to your computer, hover over the file with your mouse pointer in Windows Explorer and it should diplay information about the file, includiing bit-rate. Or you can open the files up in MP3Tag; there is a column for bit-rate.

Okay, they’re averaging over 150 kbps. I didn’t check all of them as I have hundreds of songs. I’m not sure what a normal bit rate would be, or how I would go about changing the bit rate for over 500 mp3 files. 

~150kbps bit-rate should be OK. Let me suggest something that will seem like it’s out of left field here, but just so all the bases are covered bear with me . . .

You mentioned you got a new player and it’s skipping as well. We hear this “skipping” problem fairly frequently here, and believe it or not 9 times out of 10, it’s because the user does not have the head/earphone plug fully seated into the headphone jack.

The headphone jack (particularly on brand new units) is sometimes very tight, and one must sometimes push and twist the plug at the same time to get it all the way into the jack. The other 1 out of 10 times the cause for skipping audio is a too low of a bit-rate (like 64 or even 32kbps). Since your files seem to be above this, either your headphone plug isn’t all the way in, or there’s another cause we haven’t encountered on this forum yet.

Indulge us and try to see if your head/earphone plug will go any further into the jack (bear down and twist; you won’t break it) and if that helps your issue.

That didn’t seem to work. I tried with multiple headsets, and I’m looking at the line on the display, and the little dot is actually skipping backwards, and eventually just quitting and moving onto the next song.

Well OK, at least we ruled that out. Sounds like the files might have gotten corrupted somehow. Do they play OK on your computer? Might try formatting the player and re-loading them. Another good idea would be to check them with ChkDsk that could possibly repair them using the /f switch before transferring them back to the player after formating.

Imo the headphone plug probably isn’t fully inserted. Try using a bit of force to get it to go all the way in. When the player is new the headphone jack is very tight. The Sandisk players play low bitrate files just fine. I have played 16kbps mp3 and 12 kbps wma files on my Clip+ using the original firmware without any issues.

To everyone here hello its nice to be here im zip.

i also have mp3s that skip. But i also am looking for answers to a problem i have, desperately. 

I have a new Pyle retro type all in one record players, that has an sd card slot for recording vinyl directly to the sd,in mp3 format.bit rate unknown.

so, after recording my records, the playback of the mp3s skip. Buy the records did not skip during recording. I noticed this problem in all my vinyl to mp3, recording stereos. Mostly Pyle brand does this…when i record vinyl directly to my Portable Tascam DR-05 skipping does not happen. How can i find the problem? Thank you guys so much!

I have experienced similar problems using an ION brand turntable with USB output to computer.

They have a community forum for users and ION techs to provide advice. (I could not find any Pyle Forums.)

Seems like the cheaper brands of turntables (ION and maybe Pyle) have poor tracking ability with LPs that were manufactured after the 1970’s (narrower grooves).  

   ->Another idea for you is to use your Pyle to export to wav files and then convert to mp3 files using iTunes???

Thanks for the reply, I realize with turntable to pc itunes ect. But id love to know why flash memory recordings on cheep turntables skip? I did find useing smaller sd usb gb, helps a bit,but still skip. Ii will head over to ion audio to see what they have to say about this.thanks again.

I know a long time went by, but did youj ever get an answer to your skipping problems? I’ve had the same problem listeining to some MP3s of old radio shows. Not all shows, just a few suddenly skip to the next episode/song in memory.

I did make contact with ion, they had no answer,except to tell me to use other types of thumb drives 2gb and smaller. It did help,but not totally. Untill the manufacturers and buyers demand better quality, problems will remain. My comments about this issue, on cheeply made turntables, was deleted by them. So i gave up. I have the ion profile pro,it records nicly with a 2 and 1 gb sd cards/ usb thumbdrives. But one i love it the American Audio TT record usb,direct to thumb drive turntable recorder,no pc needed to record high quality files. And would you belive its no longer avalable? What a ahame. Hey,goodluck!

What is the bit-rate of the mp3 files that cause the skipping problems?

Are the files encoded with constant or variable bit-rate?

ALSO, maybe your concerns about skipping could be related to a high “audio gain” setting for your recordings? Does your recording device and/ or software allow you to vary the audio gain? Maybe you could try a few variations and see how  this affects the final recording?

1 Like