Lots Of Problems

I love this mp3 but sometimes I wish I would have went with a different one. I have so many problems with it. I didn’t want to put each problem in a lot of different post so here is the list of what is wrong. Any help is appreciated.

  1. Music plays but doesn’t show up in folders. It shows music on the sd card but shows empty in internal folder.

2.Recently added doesn’t show new songs. I tried switching usb setting but nothing.

  1. Still skips. I tried to get help here but it still skips. With bought songs and songs ripped from my cds. I changed the tags with every song but still skips. Also it skips a lot less if I don’t skip to the next song but go to song list and click the song I want.

4.Freezes still but people said it was a tag issue like why it skips. It does it randomly including sometimes when I change the volume and I just restart it to fix it.

Thanks for reading.

When you say it skips, what does it do? Give some details.

It does sound like you may have a tagging problem.

Try using the free program mp3tag to edit the tags. The player needs ID3V2.3 ISO8859-1 tags.

Are you sure your music files are in a supported format? I think there are still some issues with AAC files.


When it skips it just keeps skipping all the songs. As if I was pressing the next song button but it would skip songs continuously. I use mp3 tag to change my tags and it is in the that format already.

What format are your songs in? If they are protected wma and you didn’t transfer them properly, then the  player would skip them. If they are in an unsupported format the player will skip them.

The songs are in a format that is playable. On the Sandisk website it says “The Sansa Clip Zip MP3 Player is compatible with a wide range of audio formats, including MP3, WMA, secure WMA, AAC, Ogg Vorbis, FLAC, and Audible.”  All my songs are in mp3 format. None of them were/are wma. Sometimes the songs play fine, it’s not any specific songs that skip.

Do those songs that skip on your player play okay on your pc? If so, then you could  try manually reinstalling the firmware. Sometimes the firmware in the player becomes corrupted.

If reinstalling the firmware doesn’t help, and the songs play okay on your pc, then there might be a hardware problem and you should return the player for replacement.

It could also be a problem with either corrupt files, or a corrupt file system. I would first try using a Check Disk to repair any partitoin corruption. If that doesn’t help, you can try re-transfering your files, and see if that helps.

If you didn’t try it yet, you could set the usb mode to MSC(settings, system settings, usb mode), formatting the player using the player’s menu deleting all the files on the player(settings, system settings, format), then copying the files to the player again.

Thanks for the help @halonachos117 and @JK98. I re-transferred my files but decided to reformat first. This is the second time I had to do this and hopefully the last.  :wink:

I thought since I already did it that it wouldn’t fix the problem. :flushed: