Media converter won't recognize my new Sansa Fuze 8GB

I have sansa media converter and I have my Sansa fuze connected-

the converter saysno media player connected.

I can see the sansa in my computer window

Download the newest version of the Media Converter and try again: Sansa Media Converter: Download Details

I downloaded the new version and it did see my Sansa 8gb fuze briefly,

however, now the computer does not recognize that my fuze is connected at all.

windows media player doesn’t see it, nor does the Sansa converter.

this is why people buy Apple.  My son has an Ipod nano,

loaded Itunes, it works immediately.

with the sansa, can’t see album art, the computer won’t recognize it,

the coverter won’t recognize it-

I’ve been on the computer for hours just trying to load music onto it.

what fun!

It sounds like the genius of Microsoft at work. Have you tried switching the Fuze to MSC mode? (Settings>System Settings>USB Mode>MSC). That will bypass the whole Microsoft ‘management’ of your Fuze and permit it to appear as a removable hard drive. Then you can just drag and drop files onto it.

I did get the computer to recognize the Sansa finally-I disabled the driver then reconnected,

or something like that.  the photo converter worked fine, and windows media player

loaded songs for me, however I have to watch that it doesn’t start syncing

whenver I connect it.

Album art is my next challenge, then some video.

Messages from users here are quite helpful.