M250 version 2.2.5A OK (?), but with new XP Pro install it's not detected

Does anyone know how to get Windows XP Pro’s Explorer to display the m250? The player, whether in MTP or MSC mode turns on when I plug it into a USB port on the computer, but Windows does not see it. Do I have to reinstall Windows XP and hope?? I used to have access, but had to do a new install of XP Pro and now have no access (except from my Lenovo laptop).

Things seemed to be OK with my newish m250, but my motherboard died on my main PC a couple of weeks ago and I put in a spare motherboard and did a fresh install of XP Pro, and now when I plug my m250 into the USB of the PC it is not detected. I monkeyed with Add Hardware for a while but it seems useless. Is there something I can do to get it detected? I’m going to have to do a fresh XP Pro install in a few days when my new motherboard gets here. Any tips appreciated.

I tried opening Windows Media Player, but I can’t seem to access the m250 from it either. 

Edit: I tried my laptop and the m250 seems to be detected fine still on it. It too runs XP Pro. So, I guess I have to assume that it’s an issue with my XP Pro install on my PC. That install is temporary, as I say. Anyway, I wonder if anyone knows any tricks to get XP Pro to detect the m2xx. BTW, while working out my PC problems the last couple of weeks, I had to use a second PC for a while that runs Windows 2000, and the m250 was detected and I did write some MP3s to it. The m2xx doesn’t specify support of Windows 2000.

Message Edited by Muse on 03-19-2008 06:02 PM

Message Edited by Muse on 03-21-2008 12:31 PM

Message Edited by Muse on 03-21-2008 12:32 PM

Oddly, I’m getting recognition from my Hercules GTXP’s breakout box’s USB connection, but not the USB connections on the front of my PC. Well, I have a workaround…

I am having the same exact problem. My Sansa m240 was working fine but now when I connect it to my pc running XPpro (MSC mode) it does not appear in the device list. I hear the “ding-dong” sound indicating that Windows has find the device but nothing else. In the task bar the device appears as a USB storage device, but without any letter assigned to it! Suggestions?

Thanks! 

Linkerr, if you find an answer, post here. I’ll do the same. BTW, I normally connect in MTP (autodetect) mode.

Since you use MSC mode, I’ll quote part of a user review I saved that seems very interesting. I haven’t done this but this guy evidently knows what he’s talking about. Don’t know if this will help with your non-detection problem, however:

" Don’t even waste your time using the installation disk or Windows Media
player with this thing. It will cause you to lose your mind. Instead,
download Mediamonkey for free. It will index your player and Windows
will install your files for you. ***Important*** Even though the manual
and Sansa website shows that playlists are supported, it may be a
mystery as to why they don’t appear on your player. Here’s how you do
it. Using Mediamonkey, Right click the Sansa Player --> go to Properties
–> go to Synchronization Properties --> and ensure that copy playlists
is checked with " \Playlists\ " in the destination directory. The player
also needs to be in MTP mode while this is done. Settings --> USB -->
Auto Detect. This will solve any headache that you may have in
automatically entering playlists onto the player. "

The above is from this page:

http://www.amazon.com/review/product/B000BP8AY2/ref=pr_all_summary_cm_cr_acr_txt?_encoding=UTF8&showViewpoints=1  

Message Edited by Muse on 03-23-2008 08:06 AM

Message Edited by Muse on 03-23-2008 08:08 AM