m240 not working anymore :(

I’m having a problem with my mp3 player. It’s a Sansa m240 1GB. I recently got Vista for  my computer, and my mp3 player would keep getting errors when I tried to add music to it, which I wouldn’t get when I had XP. A message popped up saying to format the device, so I clicked yes; it then said that the device couldn’t be formatted. But now my mp3 player shows up as an MTP device (it showed up as sansa before), and I can’t send music to it at all. On the player itself, when I go to the play music area, it says it has no files. Under information, I have m220 version 3.2.8a, 00 mb used and 00 mb available, 2340 songs and 107 recordings. So not only was I not able to add music, but now my mp3 player itself seems to not be working :frowning: If anyone knows how I can fix this, I’d be very thankful.

Message Edited by jadesage on 09-14-2007 02:51 AM

Have you reviewed the videos pretaining to Windows Vista?

Videos Click Here

And Here

No, but I just did. The problem is that I can’t see any folders or anything when I plug in my mp3 player now. Although I did see that I chose the wrong format option (the video chose FAT32, but I thought I was supposed to choose NTFS). But as I mentioned earler, it won’t let me add any music or try to format it correctly, so the videos aren’t really that helpful at this point. I should mention that I tried using the Sansa Firmware updater after this happened, but when it said to connect the mp3 player, it acted like I hadn’t plugged it in. And when I disconnected it, I got a message on my mp3 player “Error! Plz connect UM.” I had also tried to make a recording to see if it would show up when I connected it to the computer, but I just get a message saying “Device is full”. Is there any way I can fix this mess?

Message Edited by jadesage on 09-14-2007 01:09 PM

Message Edited by jadesage on 09-14-2007 01:14 PM

I am frustrated to the limit!! I have 21 songs on my m240 but only ONE will give any sound. How do I erase the entire content? I tried online, via my PC. etc…nothing will erase this stuff. In short, I want to start all over again. HELP!!!

Have you tried reformatting? This will erase everything.

Here are videos on formatting.

Click Here

It works on Windows XP?

Study it somemore.

Perhaps someone with Windows Vista can help?

I hafe XP on my home desktop and Vista on my home laptop. Here at work I have 2000. How do I use 2000 to delete songs on my m240?

I don’t know about 2000? Can you delete with XP? Shouldn’t
you get back to work?:robotsurprised:

Have you used the videos?

Click here for videos

More videos on deleting,etc
Click here

Anyone know how to fix my problem?

My sansa works on my notebook. I have vista and i have no problems you should download the firmware for it … What kind of notebook do yuo have?

Gateway MT6451 Notebook PC with Vista Home Premium. I think the main problem is that I had an error with reformating my  mp3 player, so now it’s not recognized as an mp3 player on my computer, so it can’t be reformatted or use the firmware updater.

Edit: It’s now working :smiley: The main problem was I needed to get into MSC mode to format it, but ever time it turned off it would reset to MTP, which won’t work with Vista (or at least, not mine :P). So what I decided to do was change it to MSC mode, lock it, and leave it on when I connected it to my computer. That left it in MSC, allowing me to format it to FAT. Then it started working and I could add my music :smiley: So my issue is resolved :slight_smile:

Message Edited by jadesage on 09-16-2007 02:42 AM