sansa m240

i got a sansa m240 today and when i turn it on it says intializing then

it says [v 4.0.44A Sansa m240 1.0GB] and wont do anything at all

what’s wrong with it? 

nobody can help me?

so more info, i know the player is plugged in bc when i plug it in it powers up

please help me! 

i found this

http://www.amazon.com/Freeze/forum/Fx2GDN6NH93JLIB/Tx1186FME5VZ1I1/1/ref=cm_cd_ef_tft_tp?_encoding=UTF8&asin=B000BP50AY

 seems like ppl have the same problem and i have to send it back

i payed good money and then it brakes, last time i but from sandisk

What’s wrong with it?  It’s junk.

apperantly your just on the sandisk boards to talk trash about the players. Feel better after getting it off your chest?

A little bit.  

thats good. Always important to feel better.

I can’t say that I blame the guy. Part of the problem is that everyone seems to think that tech support or re-formatting will solve the problem. So, what do you do if your computer won’t read the device? What if you’ve called and e-mailed tech support and everything they walked you through didn’t work? What if they wouldn’t let you send it back for a new one? 

All of that happened to me. I have one that still doesn’t work. I found it in a drawer tonight and tried it again, just to see what would happen. I plugged it in, (I thinks it’s been a year now) and it still doesn’t work. I noticed a lot of answers tell people to reformat or call tech support, but no one seems to know what to do if neither of those work.

I gave up on it and got a Zune instead. Much cooler and much easier to use.