Problem with the system and windows vista

I connected my sansa m230 to my laptop with windows vista and looks like it “auto formated” and now i can’t do nothing.Tried in windows xp and olny appears the removible disk(F:) but i can’t enter or copy files to it.In windows vista appears a devide named “TCNAND0” that is full but doesn’t have files.I think the folders and the system was deleted by vista, any1 can help me?

Maybe i can download the files back or something, please i really need help,and the warranty gone.

Thank you

what happens if you try to format it on winXP?

After i format seems to work, i will make a few tests and see if it’s 100%.

But thank you, the biggest problem is fixed now.

1 more thing: i can use it on windows vista? On vista doesn’t appaers any music that is on the mp3, on xp it works.

TY

switch your modes from mtp to msc. If you transfer music in mtp, you can only see it in mtp. If you transfer in msc you can only see it in msc.

maybe your vista is seeing mtp and not your xp, hence the removable disk and the showing up as ppnand.

Go to settings>usb and select MSC as the option. Connect it back to the vista and see if your music is there.

Errr…sorry but i’m from Brazil, can u tell that thing of mtp and msc again, easier to understand?

-.-’’

u r helping me a lot, thx

Switching between MSC and MTP modes

  • Turn the Sansa on, if it is not already
  • Navigate to the main menu of the player; the menu that gives us options such as Play, Record, Settings, Info 
  • Navigate to ‘Settings’ on the main menu of the player.
  • After navigating to ‘Settings’ we should see an option that states ‘USB’ or ‘USB MODE’.
  • From here we can select MSC or MTP modes
  • Once the mode is selected, it will roll back to the ‘Settings’ menu

*Auto Detect = Plays For Sure = MTP

*Rhapsody Mode = Mass Storage Class/Device = MSC


Put the player in MSC mode.

NO problems!!!

Thanks to you now it’s good, i was thinking of crash because was useless.

Thank  you for all