m240 not recognized on any PC; cable good.

Ok- so I have my MP3s on my Sansa M240.  This is dumb of me, but I don’t have them saved anywhere else.  The M240 works and plays fine, but it won’t connect to any computer so I can copy the songs off and save them.

 I understand I could probably reset the device but I do not want to lose my music stored on it.

I searched the forum for similar problems but the solutions suggested require destructive changes that wipe the memory.

 I have tried 3 computers and 3 different cables (one is the original short 6" cable that came with the player, the other two are from another MP3 player and a digital camera).  The results are always the same; the PC recognizes that something is plugged in, but it reports that there is some problem with connecting to the device.  The specifics are different based on if I use a Vista or XP machine, but on XP this is how it goes:

 1) Starting with the m240 off.  I plug in the USB cable to the PC

 2) The m240 turns on, with the “SanDisk Initializing” screen

 3) The m240 says “USB Connected MSC” with a half-circle.  The half circle does not spin.

  1. Windows pops up a message over the taskbar which says:

"USB Device not recognized.

One of the USB devices attached to this computer  has malfunctioned and windows does not recognize it. For assistance in solving this problem, click this message."  (*)

  1. At the same time, the m240 goes to a song and starts playing it!  In the past, when connected to the computer, this never happened. It would always stay in the computer connection mode. But now, you can use the buttons, play music, go into menus, etc.  One funny thing is you can’t change the USB mode  between MSC and Auto Detect when it’s doing this.

  2. I unplug the m240 and it turns off.

 The same thing happens if the m240 was set in MSC mode or “Auto detect”, except that if it is in Auto Detect mode, step 3 above says “MTP” instead of “MSC”

Oddly, the first time I plug it in to a new USB port or a new PC, it seems to work for a few seconds (Windows sees it as a mass storage device) but then goes right back to “USB Device not recognized”.


A) I tried this with the battery in or out. Same results.  I also followed the ‘power drain’ instructions I saw elsewhere on this site. Same results as above.   (See post by  BigTex21:52 20 Feb 07 in http://www.expansys-usa.com/ft.aspx?k=77669)

B) The battery is brand new; tests at 1.52VDC on my multimeter.  Battery gauge on the m240 shows it as 100% full.

C) I tried this with the “Hold” button switched on.  Same results

D) I tried this with the “+” volume button held down.  Same results  (See:  http://www.fixya.com/support/t590713-sansa_m240_wont_turn_all_way  )

E) I downloaded the firmware updater, even though I think flashing new firmware would erase the songs; but the updater program does not even see the m240, so I can’t flash new firmware even if I wanted to.

(*) If I click the message, I get a window that says:

One of the USB devices attached to this computer has malfunctioned and windows does not recognize it.

The location of the device is shown in bolt type

  • USB Root Hub (2 ports)

    unused port

   Unknown Device

Recommendation:  Try reconnecting the device. If it does not work, replace the device.