My computer won't recognize my m230

I want to use our m230 mp3 player, so connected it to our computer which has windows xp, and it keeps coming up with the message “USB device not recognized.  …one of the USB devices attached to this computer has malfunctioned and this computer does not recognize it.”   I’ve gone to Scan Disks site and tried everything I could think of.  Please help.  Thanks, Cheryl

Try changing modes. Go to Settings on the M240 Menu.
Then find USB. Select it and try another setting.
There is Auto Detect/MTP or MSC.

Also review the User Guide and Instruction Videos.
                                                            Click Here

Let us know what happens.

Thanks.  But it didn’t work.  Any other suggestions?

Having the exact same problem.  Running XP and my compie won’t recognize the M230.  got the right usb setting and everything.  Are there drivers I need?

Did you get  your m230 to work?  Mine was fine and then one day it wasn’t recognized.  Device Manager said it didn’t have a driver, but troubleshooting showed it to have a driver.  This is very frustrating as it worked before and won’t now.  Also, device is not out of warranty.  Any help will be appreciated.  So far, changing settings doesn’t work and I’ve exhausted the FAQ and this message board, but lots of questions and no answers.

The minimum system requirement for the sansa player is Windows Media Player atleast version 10 or 11…but if you have that version try checking your device manager by Right Click on My Computer> choose Manage…Select device manager if you will see a yellow exlamation point, Right Click on it and select uninstall then unplug your player and plug it back and much better if youre using a back usb port.

Am using USB back port, XP, Media Player 11, worked fine 3 weeks ago, now won’t recognize.  Device manager says it needs a driver, but under driver update it says that the driver installed is fine.  Device says no driver, device manager says there is a driver.  Have left it plugged in with no result, have looked at all how to videos, but problem still exists.

y, my M240 is even worse than yours,

 it doesnt work after “not enough spaces” error comes, 

it cant power on at all. and computer said it cant be recognized.

when i call the tech, he asked me try to format it, sure, failed. then, they offer me a UPS code, replace it.

i am waiting the replaced one now…

Me too.  They said faulty player.

After being a proud owner of 2 e140’s and 1 e130 (512 MB version) I am very sad to say that the m240 refurbished model I got from buy.com for $12 for my sister-in-law has been an utter dissapointment.  Since day 1 it has not functioned, never actually “turned on” as I began loading it with tunes for her before even turning it on.  About 800 megs into the 1gig capacity, it gave an error “file path too deep.’”  After disconnecting the player from the XP computer, it simply would not turn on, no taking-the-battery-out trick and holding-the-menu button for 1 min, 2 min helped at all.  When initally connected the device showed up in my computer as an audio device… now, when connected, it shows up as 2 separate flash drives, E & F, and F of just gives an error message “please insert a disc”.  It looks kind of like my older e models but they actually have removable SD card storage so there’s a reason for them to be recognized as 2 devices.  The m240 is unconceivable why it would do that… whatever.  Anyway, when Vista tries to format E, it has an unknown capacity and gives errors.  XP (from 2 different computers) hangs, and hangs, and won’t format the disk no matter what.  Even through Computer Disk Mgt. which was suggested by Sandisk tech support.  All in all I am very disapointed and have to go through buy.com’s hokey return policy now for a refurbished unit that should have worked “like new” out of the box.  I am always considered myself to be a faithful Sandisk customer and truly love my e model players but I made a big mistake trying to purchase this M model on the cheap for my sis.  She’s super bummed and I look like an idiot… thanks Sandisk.  You really know how to fork up an otherwise good thing.

I have spent hours and hours on the telephone with SanDisk help desk employees and still my m230 has never worked as advertised. I will never buy another SanDisk MP3 player because I don’t have time to waste trying to get it to work right.

I spent a lot of time too and they finally just sent me a new one which I haven’t opened yet.  Instead,  I bought a ZEN and am using it OK, although it has problems too.  Since I bought it refurbished, they don’t support it (even though I bought it from them) but I found a good fix on their website.  I got tired of all the time I had to spend with Sansa and this message board isn’t much help either.  It felt like no one was really reading my problem, but just knee-jerk responding with something I had already tried.  If Sansa won’t replace it, just toss it and buy something else.

If it’s still under warranty, SanDisk will replace it.  If not, throw it away it’s useless.  I spent hours and hours with their tech support, and tried everything they said, but nothing worked.  I had just used it the day before and all was fine, but the next day I got that message.  The problem is that your device has actually malfunctioned, and if it’s not under warranty, it’s cheaper to get a new one.  I just bought a ZEN 1GB for $20 on sale today with free shipping from their website.  I have the 512 and once I got it working, it’s great.  Good luck.