m240 not being recognized on 1 computer

My son has the m240 since Christmas. We have 4 computers, and he has been using mine to rip CD’s and then transfer the songs from my computer to the m240.  Never had a problem.  He has also been able to connect to my wifes computer.  Last night he tried to connect to his own computer and the m240 would not get recognized. Plugging into a USB port he got the 2 tone beep for a USB device connected, but nothing showed up in Explorer.  No problems showing in Device Manager either.  Have tried all USB ports, re-booted computer. No effect.  From there we tried my computer and it worked, no problem. He was able to connect, get recognized and add more songs to his player.

I’ve been reading about this MSC setting. But my question is, why is the m240 working on other computers but not his?  Nothing has been changed from walking from one computer to another.

not changed on the player. but the settings/drivers and whatot are different on the computer.

Theres a chance his player is in mtp mode and his computer doesnt have the right drivers. His player would show up as removable disk if its in msc, as oppose to audio device inside of"my computer"

O.K.  So hopefully its in MTP mode and switching it to MSC will make it work on his computer as well as continue working on the other computers?

yes, but the music placed on the player in mtp mode can only be seen when connecting in mtp mode, and vice versa.

formatting and sticking to msc mode is a good bet.

Sorry. You just lost me. If the player is in MTP mode, the computer cannot see it and cannot recognize it. Therefore, I cannot place any music on it. You’re saying the player has to be in MSC mode for it to be recognized by the computer but then I can’t place any music on it. And at the moment, I have no need to format.  Am I missing something?

the mode the player is in and the playback of the music has no relation what so ever.

Only when connecting tot he computer does it matter. Its like haveing 2 flash drives in your device, if you connect the msc one, its a more standerdway of reading flash drives and the such, and less likely to run into issues.

If you use mtp, the computer sees it a audio device. If you disconnect it, you can play the music placed on the device in ethier mode, but if you wanted to say delete music, you need to know which mode you put it on the player. Otherwise you can connect it in msc while trrying to delete a song that was placed on the player in mtp, and you wont be able to find it.

O.K.  I think I understand that.  I’ll give it a try tonight when I get home from work.

Thanks for the help.

It worked.  The setting was on “auto”. I switched it over to MSC and my sons computer detected it.

:slight_smile: , glad to hear it worked. MSC is a more standered setting across the board. auto detect = MTP is a newer protocol that can have issues at times.

if her ever needs to make playlist through wmp, he will need mtp mode though. as well as if he ever decides to use subscription services.

Having more problems.  We got my sons computer to detect the m240 player. It showed up in explorer and all the songs are visible.  Saturday my son tried to add 3 songs to the player and all it would show  was “access denied.”  Player is in MSC mode.  Only other option is “Auto.” There is no “MTP” mode showing. Tried changing it back to “Auto” and the drive is not shown anymore.

Never mind.  Problem fixed. Works great now.


Message Edited by Enigma on 09-26-2007 03:23 PM

I have a Sansa M240 that has been playing music without a problem for over a year now. I have 383Mb of music on it, but when I plugged it into a new PC, the PC would not recognize it. The Sansa online support said to change USB to MSC. The PC recognizes it, but then it does not show the stored music. I change it back to USB mode and still cannot see the music on the computer. However, I can play the music on the device without a problem and can see all of my music via display screen but just cannot see it via the PC.

How can I get the PC to recognize the music?

Message Edited by kcbrooks1 on 01-29-2008 08:55 AM

your computer sounds like its not recognizing the player in mtp mode. Try updating to wmp11 ( or reinstall). I am assuming you are on a windows XP computer, is that right?

Im having the same issue…

my player isnt recognised in MTP (it shows when I plug in the taskbar but when I go to explorer theres no Sansadisc or removable driver there)

Is there another way to solve this?? I dont wanna update to WMP11 :cry:

Im on a Windows XP ServicePack2

Message Edited by bmn on 02-01-2008 04:29 PM

I’m not sure why it does this either…
they say if it’s MPT format then comps have trouble recog. the usb device… but oh well.
i finally read your comment an tried to plug in the m240 onto another computer and it worked.

that’s good enough for now… but wow… what a nightmare initially