m240 USB connection problem !!


First, sorry for my english !

I read everything in the forum and anything works !

I have windows xp pro sp2. When I connect my m240, a F:/ device appear, but I can’t go in. In the device control, there is no yellow ! or ?. On the m240, it’s write «USB Reading Data… MSC ». I tried the MSC and the MTP mode, and anything works. In MTP mode, a windows opens and ask if I want to open WMP or winamp. But the mp3 player isn’t in My Computer…

What could I do ? I juste want, like in the past, drag-and-drop my music in my mp3 player…

Thank you very much!

Someone else here may be able to help.

In the meantime you may want to go to this
Sansa page and click on the language you
speak in the drop down box in the upper
right of the page. You can get support in
your language.
                               Click Here

We can help here too.

Ok, I’ll take shot at this one. Your english leaves a lot to be desired so, I’m neven sure that I totally understand your question but…
I just had what I “think” is a similar problem setting up my M240. The software is NOT self-installing, and the instructions that come with the player are seriously lacking with regards to installation instructions.
Be that as it may, your problem “may” be that when the player is in it’s default MTP mode, it is not accessible by the normal My Computer window. It can only be accessed via an application like Windows Media Player where you must “sync” to the MP3 player. If you select MSC in the player’s settings menu, you will find that the player now shows up in the “My Computer” window as a removable drive where you can do simple “Drag & Drop” file transfers.
If this isn’t your problem, you may be having the same problem I initially had, the software wasn’t getting installed properly so the driver wasn’t getting installed. This was causing a couple issues:

  1. Windows Media Player couldn’t “see” the M240.
  2. I kept getting an error message when trying to install the driver.
    In the end, I got it all working but to be honest, I’m not totally sure how. I tried doing the install several times but it failed each time. I tried going to the USB settings via Device Manager and reinstalling the driver but it failed too. I finally did that one last time and for some reason it worked. THEN everything else started to work.
    Bottom line, the SanDisk software is VERY hard to install.