less than 6 month old SanDisk Extreme Portable SSD has 300 GB of data on it but suddenly no files show

I was working on updating some files on my Extreme SSD last night when suddenly no files show on the sick. I’m on a Mac Mini with Big Sur. When I right click and chose get info it shows over 300 Gb of 1Tb used, but I can’t see any of my folders. I used the free download program RescuePro included with this Costco purchase, but it didn’t work. Tech support says I can send it in to their data recovery lab, for $100 diagnostic fee to start working on it.
Any suggestions on how I might access these folders?

Well, problem solved, at least partly. I took the drive to my laptop last night and it worked normally. I’m thinking an automatic OS update is the culprit and now wonder if it’s possible to update the drivers on Sandisk Extreme Portable SSDs. This is the 2nd drive I’ve had this problem with so far and have 1 more new one that replaced the 1st when I could use it.

Hi @Cheryle,

Please be informed that SanDisk®’s warranty does NOT provide for data recovery or reimbursement for data recovery services. The SanDisk® warranty covers the product itself but does not cover any damages (monetary loss claims) due to data loss.

Please contact the SD Technical Support team for best assistance and troubleshooting:
https://kb.sandisk.com/app/ask

There are no drivers, it’s just a drive.

If powering a larger drive off usb, perhaps the port can’t handle the power demand, external drives tend to be more reliable when using a good self powered usb hub.

#SanDiskUserRewards