iXpand Fails to sync with camera roll

I just purchased the iXpand 64 GB flash drive, and after charging the battery and installing the SanDisk iXpand app, plugged it in to my ipad 4 and tried to copy photos from camera roll to the flash drive.  If I do a manual sync, I get a message that says: “failed to sync camera roll” that flashes on the bottom left of the screen for about 3 seconds.  There is a small circular pause icon that comes up with this, and if I click that, I get a message that says “sync paused.”  If I re-click it the message says “preparing to sync.” However, nothing transfers to the flash drive.

If I turn on Automatic Sync, I get a message that says: “Failed to sync camera roll.”  If I go to the photos folder and click the plus sign I get a message that says: “Error Failed to load photos.”  

What is going on?  Am I doing something wrong?

go into settings > privacy > photos on the ipad and make sure you have allowed access for the ixpand sync app. When you first install the app it will ask if you want to give permission to access your photos. You may have hit no with will case the failed camera roll sync. 

When my iXpand is syncing with my camera roll, it tells me the file is too big over 4 GB and that there’s no storage on my iXpand. It’s brand new, just pulled it out of the box. It’s a 64gb device. Why will it not transfer?

the ixpand only supports the FAT32 file system. A limitation of the FAT32 file system is that single files cannot be larger than 4GB. Unfortunately you will not be able to store a single file larger than 4GB on the iXpand drive. 

Just got the new ixpand 64gb flash drive. It works with music and films I’ve loaded but when I try’s to back up my picture roll it makes so many files in years but when you open them there is no contents. Not one picture! Help?



i am also having this issue with my iphone6. I am trying to copy / back up / transfer my photos (4665) to my ixpand and each time it will copy 365/376 but then every other one fails?! I’ve tried lots of ways and after spending quite a lot of money for me on this I have to say I feel at the moment like it’s a waste of money! Any ideas?? 

Thanks in Advance



Please bump for Andy’s question. I am having the same issue. Nearly all of the photos show as “failed” when attempting to transfer from the iPhone to the Sandisk. IOS software up to date. Done hours of research and no luck.

1 Like

I’m having exactly the same issue. Most of my files fail. I think after a couple of hours, 3 photos transferred. :confused:
What gives?

1 Like

Bear in mind that in transferring photos, etc. from your phone or iPad to the iXpand drive, it uses your available memory on the phone or iPad, just as your computer uses the available RAM it has when copying for transfer to another place, or drive.

If your phone’s (or iPad’s) camera roll contains a lot of photos, etc. and your available memory is low AND you’re trying to copy it all the the iXpand drive, it won’t have the available resources to do it. You might have to do it a few at a time.

1 Like

Perfect! I’ll give that a try & delete everything I can off it to make some room. 

Thanks for your response 

I don’t think that’s entirely true.  I tried transferring 1 at a time and they failed.  No matter what I do they still fail.

No, that’s not the issue.  I copied one at a time and it still didn’t work.  Nothing works on this thing.

Agree with the above. Struggling to download photos from my iphone 5S. Almost all photos that I select ‘Failed’ to transfer. Randomly 1-2 would transfer. Both the IOS & ixpand software are latest.

My Instagram 850 odd photos transferred without any hastle though. Went to my local vendor in Dubai (E-Maxx) . Told them the problem. They just replaced the item. But facing the same issue again.

Hence iám here to find a solution. 

As somebody mentioned that the phone should have enough memory (similar to RAM) to be able to transfer photos. So i deleted 300 odd photos from the total 1800 (16 GB phone). But that defeats the purpose of this product. We have bought this product to be able to transfer ''ALL"" photos at one go.Without having to delete 10-20% photos …!!!

Hoping a technical expert from SanDisk can assist.

Agree.I too tried it. Cannot download camer roll photo from my iphone 5S.

Keep getting ‘failed’’ message for 99.9% photos. 

Agree.I too keep getting the ‘Failed’ message everytime i try to transfer photos from my camera roll.

Have updated software. 

Managed to download 850 odd photos from my Instagram account as backup without any hassle.

Even deleted 300 odd photos from my total of 1800 photos. To avoid the low memory issue on the phone.

Surely there should be a solution to this?

Do you have iCloud photo library enabled? If so there can sometimes be an issue with connecting to iCloud which can cause transfer failures. If you see All photos when you access the native photos app iCloud photo library is enabled. A couple of things you can try

  1. Ensure you have a valid internet connection. If you are using WiFi try LTE and if you are using LTE try wifi

  2. Try turning off iCloud photo library and attempt to re-transfer the files. See if you see the same failed message

When syncing with the camera roll, the iPhone network access symbol flashes continuously and the trasnfer speed crawls.

When I put the phone in Airplane mode, thus cutting out the network, the files flash by at high speed. 

My guess is that this has something to do with iCloud. Can anyone explain what? Does this mean that the lion’s share of my photos (gigabytes) are up in the cloud and the iXpand is fetching them down one-by-one?

@eeprofessor wrote:



My guess is that this has something to do with iCloud. Can anyone explain what? Does this mean that the lion’s share of my photos (gigabytes) are up in the cloud and the iXpand is fetching them down one-by-one?



correct, if most of your data is actually on iCloud the transfer speed will be directly related to the Internet connection speed as it must download the file first. 

You can check how many pictures are actually stored locally on your iOS device by turning off iCloud photo library. Once it is turned off give it several mins to fully desync the connection and then look at the native photos app under albums. You should not see an album named camera roll instead of all photos. Her it should tell you how many pictures you have stored locally on the iOS device. 

I just bought this straight from the box,same problem as everyone on this thread…i need a viable answer or i will need a refund.I am very much needing to back up aLL my vids and photos,I’m not willing to lose even one. Please respond,thankyou.

I haven’t seen a single post by Sandisk staff in all of those forums. Seems like it’s not even monitored. I’ve bought a 128Gb Go version few weeks ago. It’s awful, it’s terrible. And it seems like no one cares.

My post: Sandisk iXpand is a total scam!

I tried to make Amazon review, but their censorship doesn’t allow it to be published. Scammers!