Sandisk iXpand is a total scam!

I purchased the latest iXpand Go 128Gb device just recently. It was advertised everywhere as a real solution to copy photos, files and watch videos from the flash drive. The reviews, the official website and its instruction manuals touted this product supports most common video formats. Instead, it’s all lies.

First of all, this piece of disappointment called a companion app (SanDisk iXpand™ Drive) is totally useless. The UI/UX feels even cheaper than most of the chinese apps for similar chinese products. Students in primary school could’ve done it better. No clearly understandable menus, picture cards instead. Most important, there is no settings menu at all. You can’t control the app behavior. But that’s not all. There’s lies everywhere around this product.

As I said all the marketing bullshit around is touting AVI/MKV support. Check their manual, page 4: https://downloads.sandisk.com/downloads/um/ixpand-drive-um.pdf

Video WMV, AVI, MKV, MP4, MOV, FLV, MPG, RMVB, M4V, TS

It clearly says there’s a support for those video file formats.

But there is no support for MKV/AVI files whatsoever! When I open these files in companion app (SanDisk iXpand™ Drive), it says that “iOS doesn’t support this video format”. Haha, thanks captain obvious, but I’m not opening these files in native iOS Videos app. Of course iOS doesn’t support these formats. That’s why I pay premium price for a premium product! To get this support! But instead it’s trying to sell me some 3rd party paid app to watch these videos! You’ve heard it right! They’ve got built-in web browser in their app that shows a so-called “Do more store” which features some apps from 3rd party developers which support the iXpand drive video playback. There’s only 2 apps available: Infuse and nPlayer. Infuse costs $30. Can you imagine? I already paid premium price to get this junk, and now I have to pay again to get it play my videos! There’s a “free” nPlayer version, but it doesn’t support iXpand, even though it is advertised.

There’s more. Before there was a support for all those advertised video formats. But this greedy company made a second app called “Sandisk TopReel”, and moved a video playback into this app, and sold it for 5$. I checked out their support forum, and turns out they were giving away the free redeem codes for that app to those who was complaining about such business decisions. It probably worked. Until now. Turns out this official “TopReel” app is not available anymore. They removed it from the App stores worldwide on 16th of November, 2020. Just before I bought this flash drive. There is an article explaining that: https://kb.sandisk.com/app/answers/detail/a_id/23339. So the only option now is two paid apps from 3rd party, one of which has a completely insane price tag.

+Another important problem I want to complain about is file name changes. When I use photo backup feature, it changes my file names from IMG_3456.jpg to some 96b866d9f0ff5592-photo.JPG, which breaks my library and file organization completely. The original file name is not preserved in the image metadata. Whenever I’m copying the photos manually, it still changes the name. Instead of IMG_3456.jpg I get IMG_3456~photo.JPG, which also breaks it. These name changes are unnecessary. But I ran through support forums and it seems like people were complaining about this “feature” for years and it’s still not fixed (2020).

+Another issue happens when I use the built-in “Camera” function that supposes to save the photos and videos directly onto the iXpand drive. When I’m recording the video, almost every time it only records about 5 seconds of video, and then the screen becomes black, and the error message “Error Failed to create video” appears. Almost every time. When I’m taking photos and press the shutter button repeatedly, the same error message pops up “Error Failed to create image”. And sometimes it just crashes during the capturing process.

+Also the companion app (SanDisk iXpand™ Drive) occupies the device’s internal memory even when iXpand isn’t plugged in. This issue was also reported by some other users on support forums. It seems like there’s some garbage cache files left inside the App, the cache size increases every time you copy something into the iXpand flash drive, it does not clean that cache automatically, but there’s no way to clean that cache. Last time the companion app took 11.6 Gb of memory on my iPad (you can check app storage usage it in General options/Storage in your iOS settings). The only way to free that space is to delete the SanDisk iXpand™ Drive completely and reinstall it again.

+Also note that official Amazon page states “Read Speed 130 Megabytes Per Second”, while in fact there is only 90 MB/s read speed. Write speed is only 35-40 MB/s.

The consumers feedback has been ignored for years. This unfinished and semi-competent product is advertised as premium and has a premium price. It is still usable for photos backup (with some reservations), but no more than that.
I’m just trying to understand, how is it possible that a company Western Digital, one of the world leaders in data storage technology has come to such a miserable end? How comes their premium products are full of deception and doing a consumer fraud? I’m surprised there’s still no class action lawsuit. I want my consumer rights to be protected. I demand the advertised features back and the addressed issues fixed.

edits: added new issues, fixed mistakes.

3 Likes

I agree that this product is substandard and overpriced. I have been scammed. :frowning:

2 Likes

It’s a storage device, not a media player. Its purpose is to store files, not to play them. So yes, you need a compatible player to play your mkv files.

It doesn’t matter what storage device you get, you will always need to also buy a media player app or find a free one. The same app should work for all your storage devices.

As for the read speed, it depends on what you’re reading and how. If you plug it into a USB 2.0 port, you’ll only see about 60 MB/s because USB 2.0 isn’t capable of transferring data faster than that. Also, the quoted speed is for purely sequential reads, that is, if you read a big file from start to end, you should see 130MB/s. If you try to read a bunch of smaller files, or if you read one big file in smaller chunks jumping back and forth, the speed will definitely be much lower.

The only thing I really agree with you here is the app’s cache issue. That just can’t be forgiven.

But then again, all storage devices work this way and they’re all advertised the same way too. I really don’t see an issue here. As for the app, I don’t know how exactly iOS handles external storage devices, but I really don’t think you need a special app for that.

I agree this App reeks of Fraudulent activity.
I don’t know how you forgot to mention the Small photo viewer which is animated while you back up photos. It quickly and randomly displays photos, hundreds per minute as if it were displaying the photos as they transferred over. Yet after 5 minutes the progress displayed “9 out of 55,402 photos”. Like huh, maybe they should be using that processing power to store the data and not display this BS irrelevant display.
I seem to have no control over the upload speed. Sometimes it’s 2 photos a minute but today even when it was going the fastest I’ve seen it I was only able to transfer about 1,000 before I needed to unplug it to charge the phone. Since interrupting that backup I’m back to the 1 photo every couple minutes speed.
This device is trash.

1 Like