Is the Sandisk Media Converter working or not somewhere ?

I’m trying to use the Sandisk Media Converter - and i have no success at all … The product simply don’t start ; i double click it and nothing… I know it is trying to run because it is in the task list, and i have a froozen square in the middle of the screen, but the product simply don’t start.

Now, how in the world did you make it work on your system (i’m seeing posts saying they are converting video with it… (!?*?!)

I’m running Media Monkey (free) to synchronized all my music (tags, cover, etc.) - this is working great and i have no problem at all working with my collection of MP3, albums and all. Unfortunatly that product does not manage videos…

I downloaded the latest SMC available (smc-4220.exe) from Sandisk (Intervideo inc.). I tried to run ‘‘Any Video Converter’’ but when i try to read the AVI file it built on my Sansa, the Sansa is giving an error message stating it has to be converted with the Sansa media Converter (???). AVI is AVI - did Sandisk re-wrote the AVI standard ??

Quite frustrate about such poor end of the line quality  

I’m running Windows XP SP2. 

I am able to open my converter, but it says “no available player”, “please connect your player”. My player says “connected” and if I go to “my computer” (on my computer), it shows that my e260r is there. Any ideas? Thanks.

You might not be using the right USB mode - try changing it (i can run mine under both mode, but MSC seems to be required for the SMC).

On my adventure with SMC and the support. I’m still waiting on line for support :angry:

Latest on my problem : it seems to be related to the system language i’m using (i’m running a french system and Winxp french version as well). If i change my setting to US ENGLISH, i then get an error message saying : Application Failure  sansa media converter.exe 0.0.0.0 in gdiplus.dll 5.1.3097.0  at offset 00009697

I don’t have problem running the same product on an ‘‘all english’’ system.

Message Edited by regg001 on 01-05-2008 11:11 PM

How fast is your computer?  Sansa Media Converter seems SLOW- I have to wait for it to start an excessively long time.

I would not try to convert any files that are already on your Sansa. Copy them back to the computer and convert them from there.

I have used www.arcsoft.com 's “media converter” successfully-

You can also try this thread-

http://forums.sandisk.com/sansa/board/message?board.id=smc&thread.id=320

Message Edited by AutobahnSHO on 01-05-2008 08:47 PM

Hello Autobahn and thanks to jump in.

The product seems ok on my laptop (english Win XP), beside i’m not planning to put huge amount of video on it - and it is doing the job at a good pace. Still i’d like to make it work on my desktop (french Win XP).

I’ve seen the arcsoft products, but i don’t want to pay for a product that is supposed to work (and included on the base product).

I also tried Any video converter free. It seems to work, but i can’t find the exact format of the file that will fit on the sensa. I’ve tried AVI, MP4, both unnacceptable to the e280v2. When i try to copy the file, the sansa does not accept it saying the file is not compatible with it.

News from SANDISK : they sent me the address to download SMC V2 (the same i already downloaded twice today), so the answer flew back to the support center to say it was not the right blind pick to fix that issue. So back to waiting again.

Message Edited by regg001 on 01-06-2008 12:40 AM

Message Edited by regg001 on 01-06-2008 12:42 AM

It’s probably the size/ framerate.  There was a thread that told what specifics to use any video converter in, but I don’t remember who posted it.

It’s on page 1 though, in a thread I’ve posted in…

For whatever reason my Sansa has always been ok w/ Sansa’s media converter OR arcsoft’s version and Windows Vista Home Premium.

–But then I’m careful to not put too much crap on my computer and not use crazy file types downloaded off “teh internets” (Virus alert!!)

It’s weird, and getting weirder.

This morning i found an old version of SMC from Arcsoft this time (version 1.2.1.71). I know that version is no longer in use, but since everything is not working i gave it a try. Guess what… the software loaded correctly thoug it is not recognizing my E280V2, i was able to convert movies. But could not make that movie to work on the SANSA (!!!).

Then i went to Arcsoft, and downloaded the newest version of their converter (V2.5) on trial. Same thing, the product installed and worked correctly but could not recognized my E280V2 (both on MTP and MSC). And i could not read the MOV file created with that version (i does not even show up in the menu).

Then i gave a shot with Windows Media Player 11. It does recognized the E280V2, and i’m able to sync under MSC and under MTP as well. The problem, i got is that it created one copy of all albums and songs under MTP, and another one under MSC - now what’s that ??

And one other strange thing about my SANSA setup. On my laptop (remember all is working on it), when i do plug the SANSA i’m receiving the Window popup asking what program i want to load with it and the window is filled with programs. However when i plugged it to my desktop (where all the problems seems to be), i still got the window popup, but there’s no program listed.

So there’s somekind of issue on my desktop for sure, but it’s still not clean on the SANSA either. I will remove all the products (including Sansa updater) to see if that does fix one of the issue. I will keep you posted.

I found one of the problem with my system. Currently the latest version of SMC comes with GDIPLUS.DLL - for some undetermined reason that dll is looking for DWMAPI.DLL . That’s the point, that last DLL is working under VISTA only - and absolutly not under XP . That issue comes from IE7 with XP . Usually that DLL is optional and would not be called under XP, but IE7 also changed another one called IEFRAME.DLL (used for shading in VISTA) and then it get called so the program is failing at startup.

So that’s why my SMC is failing with GDIPLUS. I wonder why Sandisk support was not aware of such issue - known since mid 2006.

I found that if i removed IE7 (oh my god!!!) it would fixed the problem. Well… i will wait for Sansa to give me some feedback on it.

Message Edited by regg001 on 01-06-2008 05:44 PM

There’s a good thread in the e200 Forum that tells how to get the MTP thing working ok- it involves a line in the registry.

Hello Autobahn, do you mean that topic : e200 v2 - SOLUTION for failure to connect .

1- i don’t have problem to connect (the only issue i have is the SMC itself not loading/running).

2- when i connect (both MTP and MSC) it got recognized (new material detected, MTP device, then E280 etc. - so it’s not the issue.

2- the solution to reset the access rights - i already done that - found a similar issue/solution saturday night on another forum.

But thanks for your help and time.

News from the help desk, they query about my system infos - but they also asked if i was running WIN XP English or else (???) - i never told them it worked on the english one, but not on the french one - so do they already know something about FRENCH XP. I replied, and now waiting to here again from them.

On the stuff i mentionned on my previous post about a missing DLL from VISTA. Well i had the time to test further on the ‘‘working’’ laptop. It has the same missing DLL in it, but it does not cause any problem on that system. So i’m really confuse about that issue. Why a missing DLL on a system will make it failed, and it is not an issue on the other system. Furthermore, on the ‘‘working’’ laptop, there’s more DLL missing then on my ‘‘not working’’ desktop.

We are both using IE7 and WMP11 under WIN XP SP2 . Remember Laptop is English, Desktop is French XP. And finally i found another program that used to work - but is not anymore and it is failing the same way SMC does.

God (or whoever), i’m not lucky. Everytime i’m on a lead for that issue, something happen to tell me the lead is not good.

I was able to run the product successfully on a french laptop this morning, so it’s not an OS Language issue neither. Now, i’m lost.  

News update from the support team. My case has been closed :dizzy_face:  and worst ==> REQUEST CLOSED BY CUSTOMER .

WOW !!! this is big news for me, the last thing i did yesterday was a reply to all the questions about my PC, Software version and all - :angry:i did not closed the ticket :robotmad:.

So i re-opened another request tonight referring the first one. :manmad:

Still waiting for feedbacks from Sandisk support (2 days). Meanwhile, there seems to be a very close link between QuickTime and the converter. If i start QuickTime, i’m able to start the converter (!?!). It is still freezing few seconds later, but if i try to start the converter without Quicktime running, then i get the error with GDIPLUS .

Does anybody knows how the converter is updating the top/left part of the window (the part with the image of the Sansa) - that part is ‘‘transparent’’ (when i’m able to start the converter) - even when i got my sansa to connect and synchronize to it, i can see the data ok (space available/used), but the image is not there. This might be a clue to my problem. I now know that the problem is not the converter but it is somewhere in my system - i’m just trying to figure out where to look first.

I found another product failing with GDIPLUS on my system. So it is turning around display issue - it’s not the video driver dough (i tried 4 different releases of video driver).

I don’t know how to use the media converter and like other. i will go 2 it and it says that it isnt connected and to connect it. I don’t know whats wrong with it? cause i want to put video’s on it but it seems to not want to work. How do u make it work?

Your mp3 player must be connected to the computer first.

Wish me good luck.

I removed all video codec, filtered all that could be wrong/corrupted/bad about my system, removed all video drivers, removed all of Quicktime, all the .net framework, then re-installed all piece by piece - no luck, i’m still getting the same error with SMC and two or three other softwares. The problem is not within all of those. There’s something in here that is corrupting GDIPLUS (or the registry, or god knows what), and it is making many programs to failed.

Next step is to try to ‘‘rebuild’’ Winxp itself, if not able, then to start a bran-new XP system image.

I’ll let you know.

I’m having issues as well. I’m running on an older computer, but when I start it, it just sits at the splash screen forever. Nothing happens. I unplug my player, and it magically loads. I plug it in, and it either recognizes it or freezes. It’s like Russian roulette. Then when I try to transfer pics to my microSD card, it freezes and doesn’t do anything.

As far as I know media converter will not put pics or vids on the MicroSD card.

Even if you manually put them on the card, the Sansa doesn’t access them.

(Rockbox will if you have a v1.)

I usually start media converter THEN plug the player in- and as with all Windows software you have to be patient and not drag/drop/right click/ click button

all too fast or it freezes up…   Go slow and it works better…   :-<

Quick update on XP re installed. XP back working.

Out of the Winxp SP2 re-installation, the converter is not working on my system (no clue why). Re-installation must have corrected some little things because i’m now able to see more stuff (in explorer) from my Sansa then what i had before - and i’m not talking about hidden folders :stuck_out_tongue:

I’m currently re-upgrading the 90+ XP fix on my system to see if it does change the issue . Still very frustrated to see that even an XP re-installation does not change the situation.