The converter Sucks.

Like basically everyone else on here says the media converter does not detect my sansa…and I don’t have any **bleep**ing money to buy a new update converter.

This was supposed to come with a working converter, so I’m angry that I basically have to pay even more money to get it to do something it was supposed to already be able to do.   And I’m definetly not the only person it isn’t working for. 

It wasn’t worth the money.

If you have any solutions besides paying money to download another version let me know.


just try the free one @

thanks but is there one that will convert picture files also? this one only does video

You can convert them manually using photo editing software.  Look at the specs of the original pictures, change them like that, then copy them to the appropriate folder…

is it too much to ask Sansa to provide a converter that works?

Apparently so. 

Too bad they have a great little product but the software is so buggy that some people can’t use it at all, others get frustrated, and so word of mouth will prevent it from ever selling as well as it could.

Try reinstalling this version, it worked for me (the second time)

Have a try at it!



@webed wrote:

is it too much to ask Sansa to provide a converter that works?

It works, just takes the right person to make it work :stuck_out_tongue: haha.  jkjk.  Its perfectly able to do it.  Works fine with my View…

The converter doesn’t work, no matter what mode. The Sansa is going back. Too bad, I didn’t know I would have such problems with it. Too bad for SanDisk, they are losers. Ipod. Ipod.

Not sure if this will help or not, but I just bought a refurbed e280 on e-bay, and I was having trouble getting the converter to see the device. Windows recognized it and I could transfer mp3s manually and sync through MP11 without a problem. However, converting videos and photos was not working as expected. The ArcSoft converter would not see the device. I read through the owner’s manual several times before finding the section that covered “USB” modes… in the device’s main menu, under settings there is supposed to be a USB mode option, but there is not. I did find however, “MODE” which listed two options, “Rhapsody” and “PlaysForSure”. It was set to Rhapsody by default, I changed it to PlaysForSure, and the software now recognizes the device and converts photos and video without error every time. I hope this helps some of you out there.




TacheonOmega, how did you access this “MODE” you speak of, and which software are you talking about in the end of your paragraph; Sansa Media Converter or Arcsoft Media Converter?

Sincerely yours,

Message Edited by Karl89 on 12-29-2007 07:30 PM


Concerning USB modes (accessed through Settings>USB Mode on the e200):

MSC (e200) = Rhapsody (e200R)
MTP (e200) = PlaysForSure (e200R)

I have read your other posts elsewhere in the forum but haven’t had anything constructive to add until now!  :cry:  Sorry you’ve had so much trouble.  I don’t use the features of the Sansa that require media conversion so I can’t address that.

Message Edited by gorillawatcher on 12-29-2007 09:41 PM

Finally!!!   Success!!!   Thanks TacheonOmega!

On E200R series, you get to the mode as follows: 

Click the “menu” button, scroll up/down to “settings”, scroll right to settings submenu, scroll up/down to “Mode”, scroll right to mode submenu, select “PlaysForSure”.   After doing this, the converter worked for me.   

BTW, no thanks go to SanDisk who supplied me with the incorrect converter manual (for the old ArcSoft version), did a poor job of documenting this product online, and never replied to my email request for help.  After spending 3 weeks trying to convert 1 video, I can’t recommend this product to anyone due to its poor software.

Darn…I spoke too soon.    Well, the video works and works well, but if I try to fast-foward (etc) it locks up solid.  Hard reset won’t even work.   Ah wait…it finally auto-shut off.

I found out the hard way what DRM is.  I copied all the Rhapsody music off to my hard drive so there would be plenty of room for the video.  Once the video was loaded I copied it back to the same location (and ensured I copied everything correctly)  but when I went to play the music they are now blocked.   I could kick myself, because they really made some great selections for sample music!  I wonder if the download that resets it back to factory settings will reload the music too…?

I had the same issue and even took mine back and got a new one.

the new one did it also

after uninstalling the converter program and then downloading it again today, it works. 

I swear i already tried this yesturday but I think sometime today they have fixed the download  so try it once more and cross your fingers, it worked for me

BengalTigger wrote:

I found out the hard way what DRM is…  I wonder if the download that resets it back to factory settings will reload the music too…?

No it won’t, it just resets all your settings to default.  It doesn’t reload anything that was deleted. You could ask someone to email the songs to you. (I would but I have worse-than-dialup internet…)

As for playback of videos, my best luck is if you turn the player off, then turn it on and use it ONLY to view videos. If you play music then try to play video it seems to crash more.   

AND if you have to fastforward, do so then let it play a few seconds before you fast forward again, to minimize crashes.