Impossible to change/upgrade micro SD in my Wireless Stick

I’ve been trying to upgrade the micro SD of my SanDisk Wireless Stick 64Gb following the instructions provided here: 

https://it.ifixit.com/Guida/SanDisk+Wireless+Stick+16+Gb+Disassembly/87005

and here:

https://kb.sandisk.com/app/answers/detail/a_id/8075/kw/wfd?_ga=2.168244840.895628164.1580739749-1123745950.1576771054

I’ve got a brand new micro SD Samsung EVO Plus 256Gb and replaced the original SanDisk Ultra Plus 64Gb but it didn’t work

The Stick, fully charged, does not work anymore. The led flashes red 2 or 3 times and then nothing else. If I plug the stick in a usb port (tried Win & Mac) simply the computers don’t detect the stick.

I tried with different formats (exFAT & FAT32) I even tried erasing the partition but nothing.

So I put back the original micro SD and magically the stick was working like always.

At this point I decided to try replacing with other micro SD, 16, 32, 128, different brands. The result is always the same, the stick simply does not work and is not detected from computers when plugged in.

The stick works ONLY with his original micro SD. Is this possible? Is it locked on the serial number of the SD, or something similar? Has anybody experienced something like that?

Any advice will be greatly appreciated, thanks

Mancer